CVE-2020-36190
rails_admin ruby gem XSS vulnerability
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
- Record
CVE-2020-36190- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
- Record
CVE-2020-36190- Updated
- 2026-11-02
EUVDEUVD-2021-0521 No score
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
- Record
EUVD-2021-0521- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wjx2-7hqq-8h7m
6.1
rails_admin ruby gem XSS vulnerability
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
- Record
GHSA-wjx2-7hqq-8h7m- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
- Record
CVE-2020-36190- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-wjx2-7hqq-8h7m
6.1
rails_admin ruby gem XSS vulnerability
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
- Record
GHSA-wjx2-7hqq-8h7m- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
rails_adminRubyGems |
2.0.0 up to 2.0.2 | 2.0.2 |
rails_adminRubyGems |
before 1.4.3 | 1.4.3 |
rails_adminRubyGems |
before 1.4.3, plus listed versions 0.0.10.0.20.0.30.0.40.0.5 Show 36 moreShow less0.1.00.1.10.1.20.2.00.3.00.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.4.80.4.90.5.00.6.00.6.10.6.20.6.30.6.40.6.50.6.60.6.70.6.80.7.00.8.11.0.01.0.0.rc1.1.01.1.11.2.01.3.01.4.01.4.11.4.2 |
1.4.3 |
rails_adminRubyGems |
2.0.0 up to 2.0.2, plus listed versions 2.0.1 |
2.0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-36190 is a medium vulnerability (CVSS 6.1) in Rails Admin Project Admin, published January 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.29%, the 70th percentile. Fixed in rails_admin 2.0.2.
References
github.com/sferik/rails_admin/blob/master/README.md
github.com/sferik/rails_admin/commit/d72090ec6a07c3b9b7b48ab50f3d405f91ff4375
github.com/sferik/rails_admin/compare/v1.4.2...v1.4.3
nvd.nist.gov/vuln/detail/CVE-2020-36190
github.com/rubysec/ruby-advisory-db/blob/master/gems/rails_admin/CVE-2020-36190.yml
github.com/advisories/GHSA-wjx2-7hqq-8h7m
github.com/railsadminteam/rails_admin