CVE-2020-36599
OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
CVE-2020-36599- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
CVE List No score
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
CVE-2020-36599- Updated
- 2026-11-02
EUVDEUVD-2022-6596 No score
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
EUVD-2022-6596- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pm55-qfxr-h247
9.8
OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
GHSA-pm55-qfxr-h247- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
OSV
9.8
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
CVE-2020-36599- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-36599
9.8
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
DEBIAN-CVE-2020-36599- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-pm55-qfxr-h247
9.8
OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
GHSA-pm55-qfxr-h247- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-116
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2020-36599
9.8
lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
- Record
UBUNTU-CVE-2020-36599- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
omniauthRubyGems |
before 1.9.2 | 1.9.2 |
omniauthRubyGems |
2.0.0.pre.rc1 to 2.0.0.pre.rc1 | 2.0.0 |
ruby-omniauthDebian:12 |
before 2.0.4-2 | 2.0.4-2 |
ruby-omniauthDebian:13 |
before 2.0.4-2 | 2.0.4-2 |
ruby-omniauthDebian:14 |
before 2.0.4-2 | 2.0.4-2 |
omniauthRubyGems |
before 1.9.2, plus listed versions 0.0.10.0.30.0.40.0.50.1.0 Show 45 moreShow less0.1.10.1.20.1.30.1.40.1.50.1.60.2.00.2.0.beta10.2.0.beta20.2.0.beta30.2.0.beta40.2.0.beta50.2.10.2.20.2.30.2.40.2.50.2.60.3.00.3.0.rc30.3.21.0.01.0.0.beta11.0.0.pr11.0.0.pr21.0.0.rc11.0.0.rc21.0.11.0.21.0.31.1.01.1.11.1.21.1.31.1.41.2.11.2.21.3.01.3.11.3.21.4.01.4.11.4.21.4.31.5.0 |
1.9.2 |
omniauthRubyGems |
2.0.0.pre.rc1 up to 2.0.0 | 2.0.0 |
ruby-omniauthUbuntu:16.04:LTS |
All versions, plus listed versions 1.2.2-31.3.1-11.3.1-1+deb9u1build0.16.04.1 |
None known |
ruby-omniauthUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.1-11.3.1-21.6.1-2 |
None known |
ruby-omniauthUbuntu:20.04:LTS |
All versions, plus listed versions 1.8.1-11.9.0-1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
ruby-omniauthUbuntu:22.04:LTS |
All versions, plus listed versions 1.9.1-1 |
None known |
ruby-omniauthUbuntu:24.04:LTS |
All versions, plus listed versions 2.1.1-1 |
None known |
ruby-omniauthUbuntu:25.10 |
All versions, plus listed versions 2.1.1-4 |
None known |
ruby-omniauthUbuntu:26.10 |
All versions, plus listed versions 2.1.4-1 |
None known |
ruby-omniauthUbuntu:26.04:LTS |
All versions, plus listed versions 2.1.1-42.1.4-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-36599 is a critical vulnerability (CVSS 9.8) in Omniauth, published August 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.20%, the 68th percentile. Fixed in omniauth 1.9.2.
References
github.com/omniauth/omniauth/commit/43a396f181ef7d0ed2ec8291c939c95e3ed3ff00
rubygems.org/gems/omniauth/versions/1.9.2
nvd.nist.gov/vuln/detail/CVE-2020-36599
github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth/CVE-2020-36599.yml
github.com/advisories/GHSA-pm55-qfxr-h247
security-tracker.debian.org/tracker/CVE-2020-36599
github.com/omniauth/omniauth
ubuntu.com/security/CVE-2020-36599
cve.org/CVERecord?id=CVE-2020-36599
Left out here: 8 versions. The JSON record has them.