CVE-2020-5244
Private data exposure via REST API in BuddyPress
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.0
Private data exposure via REST API in BuddyPress
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
- Record
CVE-2020-5244- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2020-0286
8.0
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
- Record
EUVD-2020-0286- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3j78-7m59-r7gv
8.0
Private data exposure via REST API in BuddyPress
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed.
This has been patched in version 5.1.2.
- Record
GHSA-3j78-7m59-r7gv- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
NVD
8.0
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
- Record
CVE-2020-5244- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-284, CWE-200
- Updated
- 2026-11-02
OSV
7.5
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
- Record
CVE-2020-5244- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-3j78-7m59-r7gv
8.0
Private data exposure via REST API in BuddyPress
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed.
This has been patched in version 5.1.2.
- Record
GHSA-3j78-7m59-r7gv- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
buddypress/buddypressPackagist |
before 5.1.2 | 5.1.2 |
buddypress/buddypressPackagist |
before 5.1.2, plus listed versions 2.2-beta12.2-beta22.2-rc12.2-rc22.2.0 Show 45 moreShow less2.2.12.2.22.2.2.12.2.32.2.3.12.2.42.2.52.2.62.3.02.3.0-beta-22.3.0-beta12.3.0-rc12.3.12.3.22.3.2.12.3.32.3.42.3.52.3.62.3.72.4.02.4.0-beta12.4.0-beta22.4.0-rc12.4.22.4.32.4.42.4.52.5.02.5.0-beta12.5.0-rc12.5.12.5.22.5.32.5.42.5.52.6.02.6.0-beta12.6.0-rc12.6.12.6.1.12.6.22.6.32.6.42.7.0 |
5.1.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-5244 is a high vulnerability (CVSS 8.0) in Buddypress, published February 24, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.44%, the 84th percentile. Fixed in buddypress/buddypress 5.1.2.
References
Left out here: 44 versions. The JSON record has them.