Every CVE Search/ Get API key

CVE-2020-5253

Privilege escalation in NetHack

3.9 LowFix available

CVE-2020-5253 is a low vulnerability (CVSS 3.9) in Nethack, published March 10, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in nethack 3.6.0-1.

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.54%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 3.9

Privilege escalation in NetHack

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Record
CVE-2020-5253
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-184
Updated
2026-11-02
EUVDEUVD-2020-26463 3.9

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Record
EUVD-2020-26463
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
NVD 3.9

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Record
CVE-2020-5253
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-184, CWE-269
Updated
2026-11-02
OSV 9.8

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Record
CVE-2020-5253
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-5253 9.8

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Record
DEBIAN-CVE-2020-5253
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-5253 3.9

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Record
UBUNTU-CVE-2020-5253
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2025:14898-1 No score

nethack-3.4.3-6.1 on GA media

These are all security issues fixed in the nethack-3.4.3-6.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14898-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nethack
Debian:12
before 3.6.0-1
3.6.0-1
nethack
Debian:13
before 3.6.0-1
3.6.0-1
nethack
Debian:14
before 3.6.0-1
3.6.0-1
nethack
Ubuntu:16.04:LTS
All versions, plus listed versions
3.4.3-153.4.3-15build1
None known
nethack
openSUSE:Tumbleweed
before 3.4.3-6.1
3.4.3-6.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, NVD, OSV

References

MoveEnter Open