Every CVE Search/ Get API key

CVE-2020-5254

NetHack hilite_status parsing privilege escalation

3.9 LowPublic exploitFix available

CVE-2020-5254 is a low vulnerability (CVSS 3.9) in Nethack, published March 10, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.13%, the 66th percentile. Fixed in nethack 3.6.6-1.

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.13%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 3.9

NetHack hilite_status parsing privilege escalation

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Record
CVE-2020-5254
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-125
Updated
2026-11-02
EUVDEUVD-2020-26464 3.9

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Record
EUVD-2020-26464
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
NVD 3.9

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Record
CVE-2020-5254
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-125, CWE-119
Updated
2026-11-02
OSV 8.1

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Record
CVE-2020-5254
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-5254 8.1

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Record
DEBIAN-CVE-2020-5254
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-5254 3.9

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited. NetHack 3.6.6 resolves this issue.

Record
UBUNTU-CVE-2020-5254
CVSS 3.1
3.9 LowCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2021-0077 No score

Updated nethack packages fix security vulnerabilities

Updated nethack packages fix security vulnerabilities:

NetHack 3.6.x before 3.6.4 is prone to a buffer overflow vulnerability when reading very long lines from configuration files. This affects systems that have NetHack installed suid/sgid, and shared systems that allow users to upload their own configuration files (CVE-2019-19905).

In NetHack before 3.6.5, unknown options starting with -de and -i can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options (CVE-2020-5209).

In NetHack before 3.6.5, an invalid argument to the -w command line option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options (CVE-2020-5210).

In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files (CVE-2020-5211).

In NetHack before 3.6.5, an extremely long value for the MENUCOLOR configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files (CVE-2020-5212).

In NetHack before 3.6.5, too long of a value for the SYMBOL configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files (CVE-2020-5213).

In NetHack before 3.6.5, detecting an unknown configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files (CVE-2020-5214).

In NetHack before 3.6.6, some out-of-bound values for the hilite_status option can be exploited (CVE-2020-5254).

The nethack package has been updated to version 3.6.6, fixing these issues and other bugs. See the upstream release notes for details.

Record
MGASA-2021-0077
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
nethack
Debian:12
before 3.6.6-1
3.6.6-1
nethack
Debian:13
before 3.6.6-1
3.6.6-1
nethack
Debian:14
before 3.6.6-1
3.6.6-1
nethack
Mageia:7
before 3.6.6-1.mga7
3.6.6-1.mga7
nethack
Ubuntu:20.04:LTS
All versions, plus listed versions
3.6.1-1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubdpmdpm2/CVE-2020-52542020-03-09

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, NVD, OSV, PoC in GitHub

References

Show 13 moreShow less
MoveEnter Open