CVE-2020-5501
phpBB Cross-Site Request Forgery (CSRF)
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
CVE-2020-5501- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
CVE-2020-5501- Updated
- 2026-11-02
EUVDEUVD-2022-3605 No score
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
EUVD-2022-3605- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cpqc-g4r8-6hxg
4.3
phpBB Cross-Site Request Forgery (CSRF)
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
GHSA-cpqc-g4r8-6hxg- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
4.3
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
CVE-2020-5501- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-cpqc-g4r8-6hxg
4.3
phpBB Cross-Site Request Forgery (CSRF)
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
GHSA-cpqc-g4r8-6hxg- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVBIT-phpbb-2020-5501 No score
phpBB 3.2.8 allows a CSRF attack that can modify a group avatar.
- Record
BIT-phpbb-2020-5501- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpbb/phpbbPackagist |
3.2.8 to 3.2.8 | 3.2.9 |
phpbbBitnami |
3.2.8 to 3.2.8 | None known |
phpbb/phpbbPackagist |
3.2.8 up to 3.2.9, plus listed versions 3.2.9-RC1 |
3.2.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-5501 is a medium vulnerability (CVSS 4.3) in Phpbb, published January 14, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.38%, the 31st percentile. Fixed in phpbb/phpbb 3.2.9.