Every CVE Search/ Get API key

CVE-2020-7009

Improper Privilege Management in Elasticsearch

8.8 HighFix available

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.88%Up 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
CVE-2020-7009
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-266, CWE-269
Updated
2026-11-02
CVE List No score

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
CVE-2020-7009
Weakness
CWE-266
Updated
2026-11-02
EUVDEUVD-2022-3946 No score

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
EUVD-2022-3946
Updated
2026-11-03
GitHub AdvisoriesGHSA-gfv5-grx2-9jw2 8.8

Improper Privilege Management in Elasticsearch

Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
GHSA-gfv5-grx2-9jw2
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-266, CWE-269
Updated
2026-11-02
OSV 8.8

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
CVE-2020-7009
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-gfv5-grx2-9jw2 8.8

Improper Privilege Management in Elasticsearch

Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
GHSA-gfv5-grx2-9jw2
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-266, CWE-269
Updated
2026-11-02
OSVUBUNTU-CVE-2020-7009 8.8

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
UBUNTU-CVE-2020-7009
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-elasticsearch-2020-7009 No score

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

Record
BIT-elasticsearch-2020-7009
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.elasticsearch:elasticsearch
Maven
6.7.0 to 6.8.7
6.8.8
org.elasticsearch:elasticsearch
Maven
7.0.0 to 7.6.1
7.6.2
elasticsearch
Bitnami
6.7.0 up to 6.8.8, 7.0.0 up to 7.6.2
6.8.87.6.2
org.elasticsearch:elasticsearch
Maven
6.7.0 up to 6.8.8, plus listed versions
6.7.16.7.26.8.06.8.16.8.2
Show 5 moreShow less
6.8.36.8.46.8.56.8.66.8.7
6.8.8
org.elasticsearch:elasticsearch
Maven
7.0.0 up to 7.6.2, plus listed versions
7.0.17.1.07.1.17.2.07.2.1
Show 11 moreShow less
7.3.07.3.17.3.27.4.07.4.17.4.27.5.07.5.17.5.27.6.07.6.1
7.6.2
elasticsearch
Ubuntu:16.04:LTS
All versions, plus listed versions
1.6.2+dfsg-11.7.3+dfsg-11.7.3+dfsg-21.7.3+dfsg-3
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-7009 is a high vulnerability (CVSS 8.8) in Elastic Elasticsearch, published March 31, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.88%, the 79th percentile. Fixed in org.elasticsearch:elasticsearch 6.8.8.

References

MoveEnter Open