Every CVE Search/ Get API key

CVE-2020-7693

Denial of Service (DoS)

5.3 MediumPublic exploitFix available

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

4.98%Down 1.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.3

Denial of Service (DoS)

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Record
CVE-2020-7693
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O
Updated
2026-11-02
EUVDEUVD-2021-0811 5.3

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Record
EUVD-2021-0811
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O
Updated
2026-11-03
GitHub AdvisoriesGHSA-c9g6-9335-x697 5.3

Improper Input Validation in SocksJS-Node

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Record
GHSA-c9g6-9335-x697
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-20
Updated
2026-11-02
NVD 5.3

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Record
CVE-2020-7693
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-755
Updated
2026-11-02
OSV 5.3

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Record
CVE-2020-7693
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVGHSA-c9g6-9335-x697 5.3

Improper Input Validation in SocksJS-Node

Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.

Record
GHSA-c9g6-9335-x697
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-20
Updated
2026-11-02
OSVCLSA-2026-1776731780 No score

TuxCare security update for sockjs (1 CVE)

TuxCare rebuilt sockjs to address 1 CVE. Fixed in 0.3.19-tuxcare.1.

Record
CLSA-2026-1776731780
Updated
2026-11-02
OSVCLSA-2026-1784856033 No score

TuxCare security update for sockjs (1 CVE)

TuxCare rebuilt sockjs to address 1 CVE. Fixed in 0.3.18-tuxcare.1.

Record
CLSA-2026-1784856033
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sockjs
npm
before 0.3.20
0.3.20
sockjs
TuxCare:npm
0.3.19-tuxcare.0 up to 0.3.19-tuxcare.1, plus listed versions
0.3.19
0.3.19-tuxcare.1
sockjs
TuxCare:npm
0.3.18-tuxcare.0 up to 0.3.18-tuxcare.1, plus listed versions
0.3.18
0.3.18-tuxcare.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubandsnw/sockjs-dos-py2020-07-03
PoC in GitHubthewindghost/CVE-2020-76932026-01-13

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-7693 is a medium vulnerability (CVSS 5.3) in Sockjs Project Sockjs, published July 9, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.98%, the 92nd percentile. Fixed in sockjs 0.3.20.

References

MoveEnter Open