CVE-2020-7698
Command Injection
CVE-2020-7698 is a high vulnerability (CVSS 8.1) in Gerapy, published July 29, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.72%, the 77th percentile. Fixed in gerapy 0.9.3.
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
Command Injection
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
CVE-2020-7698- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
EUVDEUVD-2020-0083
8.1
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
EUVD-2020-0083- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g57j-q48p-9vm2
9.3
Command injection in Gerapy
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
GHSA-g57j-q48p-9vm2- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
NVD
8.1
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
CVE-2020-7698- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
CVE-2020-7698- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-g57j-q48p-9vm2
9.3
Command injection in Gerapy
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
GHSA-g57j-q48p-9vm2- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
OSVPYSEC-2020-44 No score
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
- Record
PYSEC-2020-44- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gerapyPyPI |
before 0.9.3 | 0.9.3 |
gerapyPyPI |
before 0.9.3, plus listed versions 0.6.60.6.70.6.80.6.90.7.0 Show 30 moreShow less0.7.10.7.20.7.30.7.60.7.70.7.80.7.90.8.00.8.10.8.20.8.30.8.4rc20.8.50.8.5rc20.8.60.8.6a00.8.6b00.8.6b10.8.6rc10.8.6rc20.8.70.8.80.9.00.9.10.9.20.9.2a00.9.2rc10.9.3a10.9.3a20.9.3b1 |
0.9.3 |
gerapyPyPI |
before 0.9.3, plus listed versions 0.6.60.6.70.6.80.6.90.7.0 Show 30 moreShow less0.7.10.7.20.7.30.7.60.7.70.7.80.7.90.8.00.8.10.8.20.8.30.8.4rc20.8.5rc20.8.50.8.6a00.8.6b00.8.6b10.8.6rc10.8.6rc20.8.60.8.70.8.80.9.00.9.10.9.2a00.9.2rc10.9.20.9.3a10.9.3a20.9.3b1 |
0.9.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases, published | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |