CVE-2020-7752
Command Injection
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Command Injection
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.
- Record
CVE-2020-7752- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P - Updated
- 2026-11-02
EUVDEUVD-2020-1423
8.8
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.
- Record
EUVD-2020-1423- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-94xh-2fmc-xf5j
8.8
systeminformation command injection vulnerability
Impact
command injection vulnerability
Patches
Problem was fixed with a shell string sanitation fix. Please upgrade to version >= 4.27.11
Workarounds
If you cannot upgrade, be sure to check or sanitize service parameter strings that are passed to si.inetChecksite()
References
Are there any links users can visit to find out more?
For more information
If you have any questions or comments about this advisory:
- Open an issue in systeminformation
- Record
GHSA-94xh-2fmc-xf5j- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
NVD
8.8
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.
- Record
CVE-2020-7752- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
8.8
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.
- Record
CVE-2020-7752- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2020-7752
8.8
This affects the package systeminformation before 4.27.11. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.
- Record
DEBIAN-CVE-2020-7752- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-94xh-2fmc-xf5j
8.8
systeminformation command injection vulnerability
Impact
command injection vulnerability
Patches
Problem was fixed with a shell string sanitation fix. Please upgrade to version >= 4.27.11
Workarounds
If you cannot upgrade, be sure to check or sanitize service parameter strings that are passed to si.inetChecksite()
References
Are there any links users can visit to find out more?
For more information
If you have any questions or comments about this advisory:
- Open an issue in systeminformation
- Record
GHSA-94xh-2fmc-xf5j- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
systeminformationnpm |
before 4.27.11 | 4.27.11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-7752 is a high vulnerability (CVSS 8.8) in Sebhildebrandt Systeminformation, published October 26, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.75%, the 93rd percentile. Fixed in systeminformation 4.27.11.
References
snyk.io/vuln/SNYK-JS-SYSTEMINFORMATION-1021909
github.com/sebhildebrandt/systeminformation/blob/master/lib/internet.js
github.com/sebhildebrandt/systeminformation/commit/931fecaec2c1a7dcc10457bb8cd552d08089da61
github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-94xh-2fmc-xf5j
npmjs.com/package/systeminformation
nvd.nist.gov/vuln/detail/CVE-2020-7752
github.com/advisories/GHSA-94xh-2fmc-xf5j
security-tracker.debian.org/tracker/CVE-2020-7752
github.com/sebhildebrandt/systeminformation