CVE-2020-8147
Prototype Pollution
Flaw in input validation in npm package utils-extend version 1.0.8 and earlier may allow prototype pollution attack that may result in remote code execution or denial of service of applications using utils-extend.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Flaw in input validation in npm package utils-extend version 1.0.8 and earlier may allow prototype pollution attack that may result in remote code execution or denial of service of applications using utils-extend.
- Record
CVE-2020-8147- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-471, CWE-20
- Updated
- 2026-11-02
CVE List No score
Flaw in input validation in npm package utils-extend version 1.0.8 and earlier may allow prototype pollution attack that may result in remote code execution or denial of service of applications using utils-extend.
- Record
CVE-2020-8147- Weakness
- CWE-471
- Updated
- 2026-11-02
EUVDEUVD-2020-0822 No score
Flaw in input validation in npm package utils-extend version 1.0.8 and earlier may allow prototype pollution attack that may result in remote code execution or denial of service of applications using utils-extend.
- Record
EUVD-2020-0822- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6pq3-928q-x6w6 No score
Prototype Pollution
All versions of utils-extend are vulnerable to prototype pollution. The extend function does not restrict the modification of an Object's prototype, which may allow an attacker to add or modify an existing property that will exist on all objects.
Recommendation
No fix is currently available. Consider using an alternative package until a fix is made available.
- Record
GHSA-6pq3-928q-x6w6- Weakness
- CWE-471
- Updated
- 2026-11-02
OSVCLSA-2026-1771891821 No score
TuxCare security update for utils-extend (2 CVEs)
TuxCare rebuilt utils-extend to address 2 CVEs. Fixed in 1.0.8-tuxcare.1.
- Record
CLSA-2026-1771891821- Updated
- 2026-11-02
OSVGHSA-6pq3-928q-x6w6 No score
Prototype Pollution
All versions of utils-extend are vulnerable to prototype pollution. The extend function does not restrict the modification of an Object's prototype, which may allow an attacker to add or modify an existing property that will exist on all objects.
Recommendation
No fix is currently available. Consider using an alternative package until a fix is made available.
- Record
GHSA-6pq3-928q-x6w6- Weakness
- CWE-471
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
utils-extendnpm |
0.0.0 and later | None known |
utils-extendTuxCare:npm From an advisory covering 2 CVEs |
1.0.8-tuxcare.0 up to 1.0.8-tuxcare.1, plus listed versions 1.0.8 |
1.0.8-tuxcare.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-8147 is a critical vulnerability (CVSS 9.8) in Utils-extend Project Utils-extend, published April 3, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.15%, the 87th percentile. No source names a fixed version.