Every CVE Search/ Get API key

CVE-2020-8920

Overoptimization leads to private information leak in Gerrit

3.5 LowFix available

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

0.37%Down 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 3.5

Overoptimization leads to private information leak in Gerrit

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Record
CVE-2020-8920
CVSS 3.1
3.5 LowCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-285
Updated
2026-11-02
EUVDEUVD-2022-3896 3.5

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Record
EUVD-2022-3896
CVSS 3.1
3.5 LowCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-g5q2-cxgq-h2rw No score

Information leak in Gerrit

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Record
GHSA-g5q2-cxgq-h2rw
Weakness
CWE-863
Updated
2026-11-02
NVD 3.5

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Record
CVE-2020-8920
CVSS 3.1
3.5 LowCVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
2.7 LowAV:A/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-285
Updated
2026-11-02
OSVGHSA-g5q2-cxgq-h2rw No score

Information leak in Gerrit

An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.

Record
GHSA-g5q2-cxgq-h2rw
Weakness
CWE-863
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
com.google.gerrit:gerrit-plugin-api
Maven
before 2.14.22
2.14.22
com.google.gerrit:gerrit-plugin-api
Maven
2.15.0 up to 2.15.21
2.15.21
com.google.gerrit:gerrit-plugin-api
Maven
2.16.0 up to 2.16.25
2.16.25
com.google.gerrit:gerrit-plugin-api
Maven
3.0.0 up to 3.0.15
3.0.15
com.google.gerrit:gerrit-plugin-api
Maven
3.1.0 up to 3.1.10
3.1.10
com.google.gerrit:gerrit-plugin-api
Maven
3.2.0 up to 3.2.5
3.2.5
com.google.gerrit:gerrit-plugin-api
Maven
before 2.14.22, plus listed versions
2.102.10-rc12.10-rc22.10.12.10.2
Show 45 moreShow less
2.10.32.10.3.12.10.42.10.52.10.62.10.72.10.82.112.11.12.11.102.11.112.11.122.11.22.11.32.11.42.11.52.11.62.11.72.11.82.11.92.122.12-rc02.12.12.12.22.12.32.12.42.12.52.12.62.12.72.12.82.12.92.132.13-rc12.13.12.13.102.13.112.13.122.13.132.13.142.13.22.13.32.13.42.13.52.13.62.13.7
2.14.22
com.google.gerrit:gerrit-plugin-api
Maven
2.15.0 up to 2.15.21, plus listed versions
2.152.15.12.15.102.15.112.15.12
Show 16 moreShow less
2.15.132.15.142.15.152.15.162.15.172.15.182.15.192.15.22.15.202.15.32.15.42.15.52.15.62.15.72.15.82.15.9
2.15.21
com.google.gerrit:gerrit-plugin-api
Maven
2.16.0 up to 2.16.25, plus listed versions
2.162.16.12.16.102.16.11.12.16.12
Show 20 moreShow less
2.16.132.16.142.16.152.16.162.16.172.16.182.16.192.16.22.16.202.16.212.16.222.16.232.16.242.16.32.16.42.16.52.16.62.16.72.16.82.16.9
2.16.25
com.google.gerrit:gerrit-plugin-api
Maven
3.0.0 up to 3.0.15, plus listed versions
3.0.13.0.103.0.113.0.123.0.13
Show 9 moreShow less
3.0.143.0.23.0.33.0.43.0.53.0.63.0.73.0.83.0.9
3.0.15
com.google.gerrit:gerrit-plugin-api
Maven
3.1.0 up to 3.1.10, plus listed versions
3.1.13.1.23.1.33.1.43.1.5
Show 4 moreShow less
3.1.63.1.73.1.83.1.9
3.1.10
com.google.gerrit:gerrit-plugin-api
Maven
3.2.0 up to 3.2.5, plus listed versions
3.2.13.2.23.2.33.2.4
3.2.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-8920 is a low vulnerability (CVSS 3.5) in Gerrit, published December 10, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 31st percentile. Fixed in com.google.gerrit:gerrit-plugin-api 2.14.22.

References

Show 4 moreShow less
This page doesn't list everything

Left out here: 33 versions. The JSON record has them.

MoveEnter Open