Every CVE Search/ Get API key

CVE-2020-9497

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via...

4.4 MediumFix available

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.79%Down 6.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.4

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
CVE-2020-9497
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
CVSS 2.0
1.2 LowAV:L/AC:H/Au:N/C:P/I:N/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
CVE-2020-9497
Updated
2026-11-02
EUVDEUVD-2020-30303 No score

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
EUVD-2020-30303
Updated
2026-11-03
GitHub AdvisoriesGHSA-9q4f-696q-fjxm No score

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via...

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
GHSA-9q4f-696q-fjxm
Weakness
CWE-200
Updated
2026-11-02
OSV 4.4

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
CVE-2020-9497
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2020-9497 4.4

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
DEBIAN-CVE-2020-9497
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2020-9497 4.4

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
UBUNTU-CVE-2020-9497
CVSS 3.1
4.4 MediumCVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVBIT-guacamole-2020-9497 No score

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
BIT-guacamole-2020-9497
Updated
2026-11-02
OSVBIT-guacamole-server-2020-9497 No score

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Record
BIT-guacamole-server-2020-9497
Updated
2026-11-02
OSVMGASA-2021-0272 No score

Updated guacd packages fix security vulnerabilities

Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's session token. This cookie lacked the "secure" flag, which could allow an attacker eavesdropping on the network to intercept the user's session token if unencrypted HTTP requests are made to the same domain (CVE-2018-1340).

Apache Guacamole 1.1.0 and older do not properly validate data received from RDP servers via static virtual channels. If a user connects to a malicious or compromised RDP server, specially-crafted PDUs could result in disclosure of information within the memory of the guacd process handling the connection (CVE-2020-9497).

Apache Guacamole 1.1.0 and older may mishandle pointers involved in processing data received via RDP static virtual channels. If a user connects to a malicious or compromised RDP server, a series of specially-crafted PDUs could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process (CVE-2020-9498).

Apache Guacamole 1.2.0 and older do not consistently restrict access to connection history based on user visibility. If multiple users share access to the same connection, those users may be able to see which other users have accessed that connection, as well as the IP addresses from which that connection was accessed, even if those users do not otherwise have permission to see other users (CVE-2020-11997).

This is an update of guacd to latest version to fix security issues. We also updated util-linux and ossp_uuid to make them co installable as guacd requires ossp_uuid.

Record
MGASA-2021-0272
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
guacamole
Bitnami
before 1.1.0
1.1.0
guacamole-server
Bitnami
before 1.1.0
1.1.0
guacamole-server
Debian:11
before 1.3.0-1
1.3.0-1
guacamole-server
Debian:9
From an advisory covering 2 CVEs
before 0.9.9-2+deb9u1, plus listed versions
0.9.9-2
0.9.9-2+deb9u1
guacd
Mageia:7
From an advisory covering 4 CVEs
before 1.3.0-1.mga7
1.3.0-1.mga7
util-linux
Mageia:7
From an advisory covering 4 CVEs
before 2.33.2-1.1.mga7
2.33.2-1.1.mga7
ossp_uuid
Mageia:7
From an advisory covering 4 CVEs
before 1.6.2-21.1.mga7
1.6.2-21.1.mga7
guacamole-client
Ubuntu:16.04:LTS
All versions, plus listed versions
0.8.3-1.10.8.3-1.2
None known
guacamole-client
Ubuntu:18.04:LTS
All versions, plus listed versions
0.9.9+dfsg-1
None known

History

History
RecordedChangedSources
affected, facts
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-9497 is a medium vulnerability (CVSS 4.4) in Apache Guacamole, published July 2, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.79%, the 56th percentile. Fixed in guacamole 1.1.0.

References

Show 25 moreShow less
MoveEnter Open