Every CVE Search/ Get API key

CVE-2021-20215

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI...

7.5 HighFix available

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.25%Up 1.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
CVE-2021-20215
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
7.8 HighAV:N/AC:L/Au:N/C:N/I:N/A:C
Weakness
CWE-401
Updated
2026-11-02
CVE List No score

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
CVE-2021-20215
Weakness
CWE-401
Updated
2026-11-02
EUVDEUVD-2021-7658 No score

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
EUVD-2021-7658
Updated
2026-11-03
GitHub AdvisoriesGHSA-432x-cpjh-37f7 No score

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI...

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
GHSA-432x-cpjh-37f7
Weakness
CWE-401
Updated
2026-11-02
OSVALPINE-CVE-2021-20215 7.5

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
ALPINE-CVE-2021-20215
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
CVE-2021-20215
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-20215 7.5

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
DEBIAN-CVE-2021-20215
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-20215 7.5

A flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.

Record
UBUNTU-CVE-2021-20215
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-4886-1 No score

privoxy vulnerabilities

It was discovered that Privoxy incorrectly handled CGI requests. An attacker could possibly use this issue to cause a denial of service or obtain sensitive information. (CVE-2020-35502, CVE-2021-20209, CVE-2021-20210, CVE-2021-20213, CVE-2021-20215, CVE-2021-20216, CVE-2021-20217, CVE-2021-20272, CVE-2021-20273, CVE-2021-20275)

It was discovered that Privoxy incorrectly handled certain regular expressions. An attacker could possibly use this issue to cause a denial of service or obtain sensitive information. (CVE-2021-20212, CVE-2021-20276)

It was discovered that Privoxy incorrectly handled client tags. An attacker could possibly use this issue to cause Privoxy to consume resources, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS and Ubuntu 20.10. (CVE-2021-20211)

It was discovered that Privoxy incorrectly handled client tags. An attacker could possibly use this issue to cause Privoxy to consume resources, resulting in a denial of service. This issue only affected Ubuntu 20.04 LTS and Ubuntu 20.10. (CVE-2021-20214)

Record
USN-4886-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
privoxy
Alpine:v3.12
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.13
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.14
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.15
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.16
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.17
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.18
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.19
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.20
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.21
before 3.0.29-r0
3.0.29-r0
Show 15 moreShow less
Affected packages
PackageAffectedFixed
privoxy
Alpine:v3.22
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.23
before 3.0.29-r0
3.0.29-r0
privoxy
Alpine:v3.24
before 3.0.29-r0
3.0.29-r0
privoxy
Debian:12
before 3.0.29-1
3.0.29-1
privoxy
Debian:13
before 3.0.29-1
3.0.29-1
privoxy
Debian:14
before 3.0.29-1
3.0.29-1
privoxy
Debian:9
From an advisory covering 9 CVEs
before 3.0.26-3+deb9u1, plus listed versions
3.0.26-3
3.0.26-3+deb9u1
privoxy
Ubuntu:Pro:14.04:LTS
before 3.0.21-7+deb8u1ubuntu0.1~esm1, plus listed versions
3.0.21-13.0.21-23.0.21-7+deb8u1build0.14.04.1
3.0.21-7+deb8u1ubuntu0.1~esm1
privoxy
Ubuntu:16.04:LTS
before 3.0.24-1ubuntu0.1, plus listed versions
3.0.23-33.0.23-43.0.23-53.0.24-1
3.0.24-1ubuntu0.1
privoxy
Ubuntu:18.04:LTS
before 3.0.26-5ubuntu0.1, plus listed versions
3.0.26-33.0.26-43.0.26-5
3.0.26-5ubuntu0.1
privoxy
Ubuntu:20.04:LTS
before 3.0.28-2ubuntu0.1, plus listed versions
3.0.28-2
3.0.28-2ubuntu0.1
privoxy
Ubuntu:Pro:14.04:LTS
From an advisory covering 14 CVEs
before 3.0.21-7+deb8u1ubuntu0.1~esm1, plus listed versions
3.0.21-13.0.21-23.0.21-7+deb8u1build0.14.04.1
3.0.21-7+deb8u1ubuntu0.1~esm1
privoxy
Ubuntu:16.04:LTS
From an advisory covering 14 CVEs
before 3.0.24-1ubuntu0.1, plus listed versions
3.0.23-33.0.23-43.0.23-53.0.24-1
3.0.24-1ubuntu0.1
privoxy
Ubuntu:18.04:LTS
From an advisory covering 14 CVEs
before 3.0.26-5ubuntu0.1, plus listed versions
3.0.26-33.0.26-43.0.26-5
3.0.26-5ubuntu0.1
privoxy
Ubuntu:20.04:LTS
From an advisory covering 14 CVEs
before 3.0.28-2ubuntu0.1, plus listed versions
3.0.28-2
3.0.28-2ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-20215 is a high vulnerability (CVSS 7.5) in Privoxy, published February 5, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.25%, the 83rd percentile. Fixed in privoxy 3.0.29-r0.

References

Show 20 moreShow less
MoveEnter Open