CVE-2021-20279
Moodle contains Stored XSS via ID number user profile field
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
CVE-2021-20279- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
CVE-2021-20279- Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-4097 No score
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
EUVD-2022-4097- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h7h6-fwpv-ggvx
5.4
Moodle contains Stored XSS via ID number user profile field
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
GHSA-h7h6-fwpv-ggvx- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
CVE-2021-20279- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-h7h6-fwpv-ggvx
5.4
Moodle contains Stored XSS via ID number user profile field
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
GHSA-h7h6-fwpv-ggvx- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-20279
5.4
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
UBUNTU-CVE-2021-20279- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVBIT-moodle-2021-20279 No score
The ID number user profile field required additional sanitizing to prevent a stored XSS risk in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.
- Record
BIT-moodle-2021-20279- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.10 to 3.10.1 | 3.10.2 |
moodle/moodlePackagist |
3.9 to 3.9.4 | 3.9.5 |
moodle/moodlePackagist |
3.8 to 3.8.7 | 3.8.8 |
moodle/moodlePackagist |
3.5 to 3.5.16 | 3.5.17 |
moodleBitnami |
3.5.0 up to 3.5.17, 3.8.0 up to 3.8.8, 3.9.0 up to 3.9.5, 3.10.0 up to 3.10.2 | 3.5.173.8.83.9.53.10.2 |
moodle/moodlePackagist |
3.10 up to 3.10.2, plus listed versions v3.10.0v3.10.0-betav3.10.0-rc1v3.10.0-rc2v3.10.1 |
3.10.2 |
moodle/moodlePackagist |
3.9 up to 3.9.5, plus listed versions v3.9.0v3.9.0-betav3.9.0-rc1v3.9.0-rc2v3.9.0-rc3 Show 4 moreShow lessv3.9.1v3.9.2v3.9.3v3.9.4 |
3.9.5 |
moodle/moodlePackagist |
3.8 up to 3.8.8, plus listed versions v3.8.0v3.8.0-betav3.8.0-rc1v3.8.1v3.8.2 Show 5 moreShow lessv3.8.3v3.8.4v3.8.5v3.8.6v3.8.7 |
3.8.8 |
moodle/moodlePackagist |
3.5 up to 3.5.17, plus listed versions v3.5.0v3.5.0-betav3.5.0-rc1v3.5.1v3.5.10 Show 14 moreShow lessv3.5.11v3.5.12v3.5.13v3.5.14v3.5.15v3.5.16v3.5.2v3.5.3v3.5.4v3.5.5v3.5.6v3.5.7v3.5.8v3.5.9 |
3.5.17 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-20279 is a medium vulnerability (CVSS 5.4) in Moodle, published March 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.00%, the 62nd percentile. Fixed in moodle/moodle 3.10.2.
References
bugzilla.redhat.com/show_bug.cgi?id=1939033
moodle.org/mod/forum/discuss.php?d=419650
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AFSNJ7XHVTC52RSRX2GBQFF3VEEAY2MS
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UFH5DDMU5TZ3JT4Q52WMRAHACA5MHIMT
nvd.nist.gov/vuln/detail/CVE-2021-20279
lists.fedoraproject.org/archives/list/[email protected]/message/AFSNJ7XHVTC52RSRX2GBQFF3VEEAY2MS