Every CVE Search/ Get API key

CVE-2021-20283

Missing permission check in Moodle

4.3 MediumFix available

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.11%Down 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.3

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
CVE-2021-20283
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-863, CWE-862
Updated
2026-11-02
CVE List No score

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
CVE-2021-20283
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2022-2009 No score

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
EUVD-2022-2009
Updated
2026-11-03
GitHub AdvisoriesGHSA-2m72-m5cw-3g9h 4.3

Missing permission check in Moodle

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
GHSA-2m72-m5cw-3g9h
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-862, CWE-863
Updated
2026-11-02
OSV 4.3

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
CVE-2021-20283
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-2m72-m5cw-3g9h 4.3

Missing permission check in Moodle

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
GHSA-2m72-m5cw-3g9h
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-862, CWE-863
Updated
2026-11-02
OSVUBUNTU-CVE-2021-20283 4.3

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
UBUNTU-CVE-2021-20283
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVBIT-moodle-2021-20283 No score

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Record
BIT-moodle-2021-20283
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.10.0 up to 3.10.2
3.10.2
moodle/moodle
Packagist
3.9.0 up to 3.9.5
3.9.5
moodle/moodle
Packagist
3.8.0 up to 3.8.8
3.8.8
moodle/moodle
Packagist
before 3.5.17
3.5.17
moodle
Bitnami
3.5.0 up to 3.5.17, 3.8.0 up to 3.8.8, 3.9.0 up to 3.9.5, 3.10.0 up to 3.10.2
3.5.173.8.83.9.53.10.2
moodle/moodle
Packagist
3.10.0 up to 3.10.2, plus listed versions
v3.10.0v3.10.1
3.10.2
moodle/moodle
Packagist
3.9.0 up to 3.9.5, plus listed versions
v3.9.0v3.9.1v3.9.2v3.9.3v3.9.4
3.9.5
moodle/moodle
Packagist
3.8.0 up to 3.8.8, plus listed versions
v3.8.0v3.8.1v3.8.2v3.8.3v3.8.4v3.8.5v3.8.6v3.8.7
3.8.8
moodle/moodle
Packagist
before 3.5.17, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
3.5.17
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-20283 is a medium vulnerability (CVSS 4.3) in Moodle, published March 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.11%, the 66th percentile. Fixed in moodle/moodle 3.10.2.

References

Show 5 moreShow less
This page doesn't list everything

Left out here: 151 versions. The JSON record has them.

MoveEnter Open