Every CVE Search/ Get API key

CVE-2021-20718

CVE-2021-20718 affecting package mod_auth_openidc for versions less than 2.4.14.2-1

7.5 HighFix available

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.40%Up 2.3 points since May 20, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
CVE-2021-20718
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400
Updated
2026-11-02
CVE List No score

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
CVE-2021-20718
Updated
2026-11-02
EUVDEUVD-2021-8132 No score

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
EUVD-2021-8132
Updated
2026-11-03
OSVAZL-7288 7.5

CVE-2021-20718 affecting package mod_auth_openidc for versions less than 2.4.14.2-1

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
AZL-7288
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
CVE-2021-20718
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-20718 7.5

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
DEBIAN-CVE-2021-20718
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-20718 7.5

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.

Record
UBUNTU-CVE-2021-20718
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2021-0280 No score

Updated apache-mod_auth_openidc package fixes a security vulnerability

mod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of- service (DoS) condition via unspecified vectors (CVE-2021-20718).

Record
MGASA-2021-0280
Updated
2026-11-02
OSVSUSE-SU-2021:1900-1 No score

Security update for apache2-mod_auth_openidc

This update for apache2-mod_auth_openidc fixes the following issues:

  • CVE-2021-20718: Fixed possible remote denial-of-service (DoS) via unspecified vectors (bsc#1186291).
Record
SUSE-SU-2021:1900-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mod_auth_openidc
Azure Linux:2
before 2.4.14.2-1
2.4.14.2-1
libapache2-mod-auth-openidc
Debian:12
before 2.4.4.1-2
2.4.4.1-2
libapache2-mod-auth-openidc
Debian:13
before 2.4.4.1-2
2.4.4.1-2
libapache2-mod-auth-openidc
Debian:14
before 2.4.4.1-2
2.4.4.1-2
apache-mod_auth_openidc
Mageia:8
before 2.4.2.1-1.1.mga8
2.4.2.1-1.1.mga8
apache2-mod_auth_openidc
SUSE:OpenStack Cloud 9
before 2.4.0-3.14.1
2.4.0-3.14.1
apache2-mod_auth_openidc
SUSE:OpenStack Cloud Crowbar 9
before 2.4.0-3.14.1
2.4.0-3.14.1
apache2-mod_auth_openidc
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
before 2.4.0-3.14.1
2.4.0-3.14.1
apache2-mod_auth_openidc
SUSE:Linux Enterprise Server 12 SP4-LTSS
before 2.4.0-3.14.1
2.4.0-3.14.1
apache2-mod_auth_openidc
SUSE:Linux Enterprise Server 12 SP5
before 2.4.0-3.14.1
2.4.0-3.14.1
apache2-mod_auth_openidc
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
before 2.4.0-3.14.1
2.4.0-3.14.1
libapache2-mod-auth-openidc
Ubuntu:20.04:LTS
All versions, plus listed versions
2.3.10.2-12.4.0.4-12.4.1-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-20718 is a high vulnerability (CVSS 7.5) in Fedoraproject Fedora, published May 20, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.40%, the 88th percentile. Fixed in mod_auth_openidc 2.4.14.2-1.

References

Show 11 moreShow less
MoveEnter Open