Every CVE Search/ Get API key

CVE-2021-21389

BuddyPress privilege escalation via REST API

8.1 HighPublic exploitFix available

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

14.8%Up 14.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 8.1

BuddyPress privilege escalation via REST API

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Record
CVE-2021-21389
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2021-2224 8.1

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Record
EUVD-2021-2224
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-m6j4-8r7p-wpp3 8.1

BuddyPress privilege escalation via REST API

Impact

It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint.

Patches

The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

References

https://buddypress.org/2021/03/buddypress-7-2-1-security-release/

For more information

If you have any questions or comments about this advisory:

Record
GHSA-m6j4-8r7p-wpp3
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
NVD 8.1

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Record
CVE-2021-21389
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-863
Updated
2026-11-02
OSV 8.8

BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

Record
CVE-2021-21389
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-m6j4-8r7p-wpp3 8.1

BuddyPress privilege escalation via REST API

Impact

It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint.

Patches

The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

References

https://buddypress.org/2021/03/buddypress-7-2-1-security-release/

For more information

If you have any questions or comments about this advisory:

Record
GHSA-m6j4-8r7p-wpp3
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
buddypress/buddypress
Packagist
5.0.0 up to 7.2.1
7.2.1
buddypress/buddypress
Packagist
5.0.0 up to 7.2.1, plus listed versions
5.1.05.1.0-beta15.1.15.1.25.2.0
Show 21 moreShow less
5.2.15.2.26.0.06.0.0-RC16.0.0-RC26.0.0-beta16.0.0-beta26.1.06.2.06.2.0-beta16.3.06.4.06.4.26.4.37.0.07.0.0-RC17.0.0-RC27.0.0-beta17.0.0-beta27.1.07.2.0
7.2.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiBuddyPress REST API <7.2.1 - Privilege Escalation/Remote Code Execution
PoC in GitHubHoangKien1020/CVE-2021-213892021-05-31
PoC in GitHubmynameSumin/CVE-2021-213892024-12-09

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-21389 is a high vulnerability (CVSS 8.1) in Buddypress, published March 26, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 14.8%, the 96th percentile. Fixed in buddypress/buddypress 7.2.1.

References

MoveEnter Open