CVE-2021-21414
Command injection vulnerability in @prisma/sdk in getPackedPackage function
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.7
Command injection vulnerability in @prisma/sdk in getPackedPackage function
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
- Record
CVE-2021-21414- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2021-0856
7.7
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
- Record
EUVD-2021-0856- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pxcc-hj8w-fmm7
7.7
Command injection vulnerability in @prisma/sdk in getPackedPackage function
Impact
As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability.
This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input.
It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
Patches
Fixed in
- @prisma/[email protected] (latest channel)
- @prisma/[email protected] (dev channel)
Pull Request closing this vulnerability https://github.com/prisma/prisma/pull/6245
Acknowledgements
This issue was discovered and reported by GitHub Engineer @erik-krogh (Erik Krogh Kristensen).
For more information
If you have any questions or comments about this advisory:
- Create a discussion in the Prisma repository
- Email us at [email protected]
- Record
GHSA-pxcc-hj8w-fmm7- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-78
- Updated
- 2026-11-02
NVD
7.7
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
- Record
CVE-2021-21414- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N - CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
7.2
Prisma is an open source ORM for Node.js & TypeScript. As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
- Record
CVE-2021-21414- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-pxcc-hj8w-fmm7
7.7
Command injection vulnerability in @prisma/sdk in getPackedPackage function
Impact
As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability.
This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input.
It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase.
Patches
Fixed in
- @prisma/[email protected] (latest channel)
- @prisma/[email protected] (dev channel)
Pull Request closing this vulnerability https://github.com/prisma/prisma/pull/6245
Acknowledgements
This issue was discovered and reported by GitHub Engineer @erik-krogh (Erik Krogh Kristensen).
For more information
If you have any questions or comments about this advisory:
- Create a discussion in the Prisma repository
- Email us at [email protected]
- Record
GHSA-pxcc-hj8w-fmm7- CVSS 3.1
- 7.7 High
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N - Weakness
- CWE-78
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@prisma/sdknpm |
before 2.20.0 | 2.20.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-21414 is a high vulnerability (CVSS 7.7) in Axiomthemes Prisma, published April 6, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.07%, the 81st percentile. Fixed in @prisma/sdk 2.20.0.