CVE-2021-21655
Cross-Site Request Forgery in Jenkins P4 Plugin
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.1
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
- Record
CVE-2021-21655- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
- Record
CVE-2021-21655- Updated
- 2026-11-02
EUVDEUVD-2022-1295 No score
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
- Record
EUVD-2022-1295- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3rj3-qp2j-4fj2
7.1
Cross-Site Request Forgery in Jenkins P4 Plugin
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
Jenkins P4 Plugin 1.11.5 requires POST requests for the affected HTTP endpoints.
- Record
GHSA-3rj3-qp2j-4fj2- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVGHSA-3rj3-qp2j-4fj2
7.1
Cross-Site Request Forgery in Jenkins P4 Plugin
A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.
Jenkins P4 Plugin 1.11.5 requires POST requests for the affected HTTP endpoints.
- Record
GHSA-3rj3-qp2j-4fj2- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:p4Maven |
before 1.11.5 | 1.11.5 |
org.jenkins-ci.plugins:p4Maven |
before 1.11.5, plus listed versions 1.01.0.11.0.101.0.111.0.12 Show 45 moreShow less1.0.131.0.141.0.151.0.161.0.171.0.21.0.201.0.211.0.221.0.231.0.31.0.41.0.51.0.61.0.71.0.81.0.91.1.01.1.11.1.21.1.31.1.41.10.01.10.11.10.101.10.111.10.121.10.131.10.141.10.21.10.31.10.41.10.51.10.61.10.71.10.91.11.01.11.11.11.21.11.31.11.41.2.01.2.11.2.31.2.4 |
1.11.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-21655 is a high vulnerability (CVSS 7.1) in Jenkins P4, published May 11, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.52%, the 44th percentile. Fixed in org.jenkins-ci.plugins:p4 1.11.5.
References
Left out here: 63 versions. The JSON record has them.