Every CVE Search/ Get API key

CVE-2021-21852

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding...

8.8 HighFix available

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.99%Up 1.5 points since Aug 19, 2021
90%50%10%1%

What each source reports

CVE List Score used 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
CVE-2021-21852
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-680
Updated
2026-11-02
EUVDEUVD-2021-9023 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
EUVD-2021-9023
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-4wx3-gv33-fjg8 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding...

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
GHSA-4wx3-gv33-fjg8
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-190, CWE-680
Updated
2026-11-02
NVD 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
CVE-2021-21852
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-680, CWE-190
Updated
2026-11-02
OSV 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
CVE-2021-21852
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-21852 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
DEBIAN-CVE-2021-21852
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-21852 8.8

Multiple exploitable integer overflow vulnerabilities exist within the MPEG-4 decoding functionality of the GPAC Project on Advanced Content library v1.0.1. A specially crafted MPEG-4 input at “stss” decoder can cause an integer overflow due to unchecked arithmetic resulting in a heap-based buffer overflow that causes memory corruption. An attacker can convince a user to open a video to trigger this vulnerability.

Record
UBUNTU-CVE-2021-21852
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ccextractor
Debian:11
All versions, plus listed versions
0.88+ds1-10.93+ds1-10.93+ds2-10.93+ds2-20.94+ds1-10.94+ds1-20.94+ds1-3
None known
gpac
Debian:11
before 1.0.1+dfsg1-4+deb11u2, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-4+deb11u1
1.0.1+dfsg1-4+deb11u2
gpac
Debian:11
From an advisory covering 106 CVEs
before 1.0.1+dfsg1-4+deb11u2, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-4+deb11u1
1.0.1+dfsg1-4+deb11u2
gpac
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu10.5.0+svn4288~dfsg1-4ubuntu1+esm10.5.0+svn4288~dfsg1-4ubuntu1+esm2
None known
gpac
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.10.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
None known
gpac
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-30.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.10.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
None known
gpac
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-4ubuntu10.5.2-426-gc5ad4e4+dfsg5-50.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
None known
gpac
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.0.1+dfsg1-41.0.1+dfsg1-52.0.0+dfsg1-22.0.0+dfsg1-2ubuntu0.1~esm2
None known
gpac
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
2.2.1+dfsg1-32.2.1+dfsg1-3.12.2.1+dfsg1-3.1build12.2.1+dfsg1-3.1build22.2.1+dfsg1-3.1ubuntu0.1~esm2
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-21852 is a high vulnerability (CVSS 8.8) in Gpac, published August 18, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.99%, the 80th percentile. Fixed in gpac 1.0.1+dfsg1-4+deb11u2.

References

MoveEnter Open