CVE-2021-22147
Exposure of sensitive information in Elasticsearch
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
CVE-2021-22147- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-732, CWE-862
- Updated
- 2026-11-02
CVE List No score
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
CVE-2021-22147- Weakness
- CWE-732
- Updated
- 2026-11-02
EUVDEUVD-2021-1968 No score
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
EUVD-2021-1968- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-45h5-r968-5xr7
6.5
Exposure of sensitive information in Elasticsearch
A flaw was discovered in Elasticsearch where document and field level security was not applied to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
GHSA-45h5-r968-5xr7- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-732, CWE-862
- Updated
- 2026-11-02
OSV
6.5
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
CVE-2021-22147- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-45h5-r968-5xr7
6.5
Exposure of sensitive information in Elasticsearch
A flaw was discovered in Elasticsearch where document and field level security was not applied to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
GHSA-45h5-r968-5xr7- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-732, CWE-862
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-22147
6.5
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
UBUNTU-CVE-2021-22147- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVBIT-elasticsearch-2021-22147 No score
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
- Record
BIT-elasticsearch-2021-22147- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.elasticsearch:elasticsearchMaven |
7.11.0 up to 7.14.0 | 7.14.0 |
elasticsearchBitnami |
7.11.0 up to 7.14.0 | 7.14.0 |
org.elasticsearch:elasticsearchMaven |
7.11.0 up to 7.14.0, plus listed versions 7.11.17.11.27.12.07.12.17.13.0 Show 4 moreShow less7.13.17.13.27.13.37.13.4 |
7.14.0 |
elasticsearchUbuntu:16.04:LTS |
All versions, plus listed versions 1.6.2+dfsg-11.7.3+dfsg-11.7.3+dfsg-21.7.3+dfsg-3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-22147 is a medium vulnerability (CVSS 6.5) in Elastic Elasticsearch, published September 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.04%, the 64th percentile. Fixed in org.elasticsearch:elasticsearch 7.14.0.