Every CVE Search/ Get API key

CVE-2021-22565

Insufficient Granularity of Access Control in GAEN Notification Server

6.5 MediumFix available

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
Low

Exploit likelihood

0.44%Down 0.2 points since Dec 10, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.5

Insufficient Granularity of Access Control in GAEN Notification Server

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

Record
CVE-2021-22565
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-284
Updated
2026-11-02
EUVDEUVD-2021-2409 6.5

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

Record
EUVD-2021-2409
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-wx8q-rgfr-cf6v 6.5

Insufficient Granularity of Access Control in github.com/google/exposure-notifications-verification-server

Impact

Users or API keys with permission to expire verification codes could have expired codes that belonged to another realm if they guessed the UUID.

Patches

v1.1.2+

Workarounds

There are no workarounds, and there are no indications this has been exploited in the wild. Verification codes can only be expired by providing their 64-bit UUID, and verification codes are already valid for a very short period of time (thus the UUID rotates frequently).

For more information

Contact [email protected]

Record
GHSA-wx8q-rgfr-cf6v
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-284
Updated
2026-11-02
NVD 6.5

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

Record
CVE-2021-22565
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:N/I:P/A:P
Weakness
CWE-284
Updated
2026-11-02
OSV 6.5

An attacker could prematurely expire a verification code, making it unusable by the patient, making the patient unable to upload their TEKs to generate exposure notifications. We recommend upgrading the Exposure Notification server to V1.1.2 or greater.

Record
CVE-2021-22565
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Updated
2026-11-02
OSVGHSA-wx8q-rgfr-cf6v 6.5

Insufficient Granularity of Access Control in github.com/google/exposure-notifications-verification-server

Impact

Users or API keys with permission to expire verification codes could have expired codes that belonged to another realm if they guessed the UUID.

Patches

v1.1.2+

Workarounds

There are no workarounds, and there are no indications this has been exploited in the wild. Verification codes can only be expired by providing their 64-bit UUID, and verification codes are already valid for a very short period of time (thus the UUID rotates frequently).

For more information

Contact [email protected]

Record
GHSA-wx8q-rgfr-cf6v
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weakness
CWE-284
Updated
2026-11-02
OSVGO-2022-0270 No score

Insufficient Granularity of Access Control in github.com/google/exposure-notifications-verification-server

Insufficient Granularity of Access Control in github.com/google/exposure-notifications-verification-server

Record
GO-2022-0270
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/google/exposure-notifications-verification-server
Go
before 1.1.2
1.1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-22565 is a medium vulnerability (CVSS 6.5) in Google Exposure Notification Verification Server, published November 10, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in github.com/google/exposure-notifications-verification-server 1.1.2.

References

MoveEnter Open