Every CVE Search/ Get API key

CVE-2021-23341

Regular Expression Denial of Service (ReDoS)

7.5 HighFix available

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.17%Up 1.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

Regular Expression Denial of Service (ReDoS)

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
CVE-2021-23341
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
EUVDEUVD-2021-0662 7.5

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
EUVD-2021-0662
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-h4hr-7fg3-h35w No score

Denial of service in prismjs

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
GHSA-h4hr-7fg3-h35w
Weakness
CWE-400
Updated
2026-11-02
NVD 7.5

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
CVE-2021-23341
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
OSV 7.5

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
CVE-2021-23341
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-23341 7.5

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
DEBIAN-CVE-2021-23341
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2021-23341 7.5

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
UBUNTU-CVE-2021-23341
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVCLSA-2026-1793304056 No score

TuxCare security update for prismjs (6 CVEs)

TuxCare rebuilt prismjs to address 6 CVEs. Fixed in 1.17.1-tuxcare.1.

Record
CLSA-2026-1793304056
Updated
2026-11-02
OSVGHSA-h4hr-7fg3-h35w No score

Denial of service in prismjs

The package prismjs before 1.23.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the prism-asciidoc, prism-rest, prism-tap and prism-eiffel components.

Record
GHSA-h4hr-7fg3-h35w
Weakness
CWE-400
Updated
2026-11-02
OSVROOT-APP-NPM-CVE-2021-23341 No score

CVE-2021-23341 in prismjs - Patched by Root

Root has patched CVE-2021-23341 in the prismjs package for Root:npm. Multiple fixed versions available.

Record
ROOT-APP-NPM-CVE-2021-23341
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
prismjs
npm
before 1.23.0
1.23.0
prismjs
TuxCare:npm
From an advisory covering 6 CVEs
1.17.1-tuxcare.0 up to 1.17.1-tuxcare.1, plus listed versions
1.17.1
1.17.1-tuxcare.1
node-prismjs
Debian:12
before 1.23.0+dfsg-1
1.23.0+dfsg-1
node-prismjs
Debian:13
before 1.23.0+dfsg-1
1.23.0+dfsg-1
node-prismjs
Debian:14
before 1.23.0+dfsg-1
1.23.0+dfsg-1
prismjs
Root:npm
before 1.17.1-aikido.1
1.17.1-aikido.1
@rootio/prismjs
Root:npm
before 1.17.1-root.io.1
1.17.1-root.io.1
node-prismjs
Ubuntu:20.04:LTS
All versions, plus listed versions
1.11.0+dfsg-21.11.0+dfsg-3
None known
node-prismjs
Ubuntu:22.04:LTS
All versions, plus listed versions
1.23.0+dfsg-11.25.0+dfsg-11.27.0+dfsg+~1.26.0-1
None known
node-prismjs
Ubuntu:24.04:LTS
All versions, plus listed versions
1.29.0+dfsg+~1.26.0-1
None known
node-prismjs
Ubuntu:25.10
All versions, plus listed versions
1.29.0+dfsg+~1.26.0-11.30.0+dfsg+~1.26.5-1
None known
node-prismjs
Ubuntu:26.10
All versions, plus listed versions
1.30.0+dfsg+~1.26.6-1
None known
node-prismjs
Ubuntu:26.04:LTS
All versions, plus listed versions
1.30.0+dfsg+~1.26.5-11.30.0+dfsg+~1.26.5-21.30.0+dfsg+~1.26.6-1
None known

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-23341 is a high vulnerability (CVSS 7.5) in Prismjs Prism, published February 18, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.17%, the 88th percentile. Fixed in prismjs 1.23.0.

References

Show 6 moreShow less
MoveEnter Open