CVE-2021-23347
Cross-site Scripting (XSS)
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.7
Cross-site Scripting (XSS)
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
- Record
CVE-2021-23347- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
EUVDEUVD-2021-1170
4.7
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
- Record
EUVD-2021-1170- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qq5v-f4c3-395c
4.7
Possible XSS when using SSO with the CLI in github.com/argoproj/argo-cd/v2
Impact
When using SSO with the Argo CD CLI, a malicious SSO provider could have sent specially crafted error message that would result in XSS on the client by means of executing arbitrary JavaScript code.
We believe the exploitation of this vulnerability is only be possible when Argo CD is connected to a compromised/malicious SSO provider.
Patches
A patch for this vulnerability is available with the v1.8.7 and v1.7.14 releases of Argo CD.
Workarounds
- Do not use SSO with the CLI when you don't trust your SSO provider
If you have any questions or comments about this advisory:
- Open an issue in the Argo CD issue tracker or discussions
- Join us on Slack in channel
#argo-cd
Credits
The issue was found during static code scanning with CodeQL and fixed by the Argo CD team. While we believed that a rogue SSO provider would pose a severe threat by itself, we fixed it like a regular bug.
The Argo CD team would like to thank Adam Gold of Snyk (https://snyk.io) for stepping up and classifying this correctly as a security issue and for his help in determining its severity. Also, Snyk kindly reserved and provided the CVE for this vulnerability.
We fully agree with Adam that this bug is a security vulnerability and justifies publishing a SA, to provide our community and users full transparancy.
- Record
GHSA-qq5v-f4c3-395c- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
4.7
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
- Record
CVE-2021-23347- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
4.8
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
- Record
CVE-2021-23347- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-qq5v-f4c3-395c
4.7
Possible XSS when using SSO with the CLI in github.com/argoproj/argo-cd/v2
Impact
When using SSO with the Argo CD CLI, a malicious SSO provider could have sent specially crafted error message that would result in XSS on the client by means of executing arbitrary JavaScript code.
We believe the exploitation of this vulnerability is only be possible when Argo CD is connected to a compromised/malicious SSO provider.
Patches
A patch for this vulnerability is available with the v1.8.7 and v1.7.14 releases of Argo CD.
Workarounds
- Do not use SSO with the CLI when you don't trust your SSO provider
If you have any questions or comments about this advisory:
- Open an issue in the Argo CD issue tracker or discussions
- Join us on Slack in channel
#argo-cd
Credits
The issue was found during static code scanning with CodeQL and fixed by the Argo CD team. While we believed that a rogue SSO provider would pose a severe threat by itself, we fixed it like a regular bug.
The Argo CD team would like to thank Adam Gold of Snyk (https://snyk.io) for stepping up and classifying this correctly as a security issue and for his help in determining its severity. Also, Snyk kindly reserved and provided the CVE for this vulnerability.
We fully agree with Adam that this bug is a security vulnerability and justifies publishing a SA, to provide our community and users full transparancy.
- Record
GHSA-qq5v-f4c3-395c- CVSS 3.1
- 4.7 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVBIT-argo-cd-2021-23347 No score
The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.
- Record
BIT-argo-cd-2021-23347- Updated
- 2026-11-02
OSVGO-2022-0869 No score
Possible XSS when using SSO with the CLI in github.com/argoproj/argo-cd
Possible XSS when using SSO with the CLI in github.com/argoproj/argo-cd
- Record
GO-2022-0869- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/argoproj/argo-cd/v2Go |
before 1.7.13 | 1.7.13 |
github.com/argoproj/argo-cd/v2Go |
1.8.0 up to 1.8.6 | 1.8.6 |
argo-cdBitnami |
before 1.7.13, 1.8.0 up to 1.8.6 | 1.7.131.8.6 |
github.com/argoproj/argo-cdGo |
before 1.7.13, 1.8.0 up to 1.8.6 | 1.7.131.8.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-23347 is a medium vulnerability (CVSS 4.7) in Argoproj Argo Cd, published March 3, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.59%, the 48th percentile. Fixed in github.com/argoproj/argo-cd/v2 1.7.13.