Every CVE Search/ Get API key

CVE-2021-23368

Regular Expression Denial of Service (ReDoS)

5.3 MediumFix available

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

3.51%Up 2.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.3

Regular Expression Denial of Service (ReDoS)

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
CVE-2021-23368
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
EUVDEUVD-2021-1108 5.3

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
EUVD-2021-1108
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-hwj9-h5mp-3pm3 5.3

Regular Expression Denial of Service in postcss

The npm package postcss from 7.0.0 and before versions 7.0.36 and 8.2.10 is vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
GHSA-hwj9-h5mp-3pm3
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-400
Updated
2026-11-02
NVD 5.3

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
CVE-2021-23368
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
OSV 5.3

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
CVE-2021-23368
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVDEBIAN-CVE-2021-23368 5.3

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
DEBIAN-CVE-2021-23368
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
Show 8 moreShow less
OSVGHSA-hwj9-h5mp-3pm3 5.3

Regular Expression Denial of Service in postcss

The npm package postcss from 7.0.0 and before versions 7.0.36 and 8.2.10 is vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
GHSA-hwj9-h5mp-3pm3
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-400
Updated
2026-11-02
OSVUBUNTU-CVE-2021-23368 5.3

The package postcss from 7.0.0 and before 8.2.10 are vulnerable to Regular Expression Denial of Service (ReDoS) during source map parsing.

Record
UBUNTU-CVE-2021-23368
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVCLSA-2026-1776299672 No score

TuxCare security update for postcss (3 CVEs)

TuxCare rebuilt postcss to address 3 CVEs. Fixed in 7.0.14-tuxcare.1.

Record
CLSA-2026-1776299672
Updated
2026-11-02
OSVCLSA-2026-1779065198 No score

TuxCare security update for postcss (4 CVEs)

TuxCare rebuilt postcss to address 4 CVEs. Fixed in 7.0.21-tuxcare.1.

Record
CLSA-2026-1779065198
Updated
2026-11-02
OSVCLSA-2026-1779324473 No score

TuxCare security update for postcss (4 CVEs)

TuxCare rebuilt postcss to address 4 CVEs. Fixed in 7.0.32-tuxcare.1.

Record
CLSA-2026-1779324473
Updated
2026-11-02
OSVCLSA-2026-1779670117 No score

TuxCare security update for postcss (4 CVEs)

TuxCare rebuilt postcss to address 4 CVEs. Fixed in 7.0.17-tuxcare.1.

Record
CLSA-2026-1779670117
Updated
2026-11-02
OSVCLSA-2026-1792164471 No score

TuxCare security update for postcss (3 CVEs)

TuxCare rebuilt postcss to address 3 CVEs. Fixed in 8.2.9-tuxcare.1.

Record
CLSA-2026-1792164471
Updated
2026-11-02
OSVROOT-APP-NPM-CVE-2021-23368 No score

CVE-2021-23368 in postcss - Patched by Root

Root has patched CVE-2021-23368 in the postcss package for Root:npm. Multiple fixed versions available.

Record
ROOT-APP-NPM-CVE-2021-23368
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postcss
npm
7.0.0 up to 7.0.36
7.0.36
postcss
npm
8.0.0 up to 8.2.10
8.2.10
postcss
TuxCare:npm
From an advisory covering 3 CVEs
7.0.14-tuxcare.0 up to 7.0.14-tuxcare.1, plus listed versions
7.0.14
7.0.14-tuxcare.1
postcss
TuxCare:npm
From an advisory covering 4 CVEs
7.0.21-tuxcare.0 up to 7.0.21-tuxcare.1, plus listed versions
7.0.21
7.0.21-tuxcare.1
postcss
TuxCare:npm
From an advisory covering 4 CVEs
7.0.32-tuxcare.0 up to 7.0.32-tuxcare.1, plus listed versions
7.0.32
7.0.32-tuxcare.1
postcss
TuxCare:npm
From an advisory covering 4 CVEs
7.0.17-tuxcare.0 up to 7.0.17-tuxcare.1, plus listed versions
7.0.17
7.0.17-tuxcare.1
postcss
TuxCare:npm
From an advisory covering 3 CVEs
8.2.9-tuxcare.0 up to 8.2.9-tuxcare.1, plus listed versions
8.2.9
8.2.9-tuxcare.1
node-postcss
Debian:12
before 8.2.1+~cs5.3.23-6
8.2.1+~cs5.3.23-6
node-postcss
Debian:13
before 8.2.1+~cs5.3.23-6
8.2.1+~cs5.3.23-6
node-postcss
Debian:14
before 8.2.1+~cs5.3.23-6
8.2.1+~cs5.3.23-6
postcss
Root:npm
before 7.0.36-aikido.1
7.0.36-aikido.1
@rootio/postcss
Root:npm
before 7.0.36-root.io.1
7.0.36-root.io.1
node-postcss
Ubuntu:22.04:LTS
All versions, plus listed versions
8.2.1+~cs5.3.23-88.4.5+~cs7.1.51-28.4.6+~cs7.3.21-1
None known

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-23368 is a medium vulnerability (CVSS 5.3) in Postcss, published April 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.51%, the 89th percentile. Fixed in postcss 7.0.36.

References

Show 16 moreShow less
MoveEnter Open