CVE-2021-23418
XML External Entity (XXE) Injection
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.3
XML External Entity (XXE) Injection
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
CVE-2021-23418- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-02
EUVDEUVD-2021-0094
6.3
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
EUVD-2021-0094- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r2mj-8wgq-73m6
5.3
XML External Entity Reference in Glances
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
GHSA-r2mj-8wgq-73m6- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-611
- Updated
- 2026-11-02
NVD
6.3
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
CVE-2021-23418- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-611
- Updated
- 2026-11-02
OSV
9.8
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
CVE-2021-23418- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-23418
9.8
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
DEBIAN-CVE-2021-23418- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVGHSA-r2mj-8wgq-73m6
5.3
XML External Entity Reference in Glances
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
GHSA-r2mj-8wgq-73m6- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - Weakness
- CWE-611
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-23418
6.3
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
UBUNTU-CVE-2021-23418- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2026:11674-1 No score
glances-common-4.5.6-1.1 on GA media
These are all security issues fixed in the glances-common-4.5.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:11674-1- Updated
- 2026-11-02
OSVPYSEC-2021-115 No score
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
- Record
PYSEC-2021-115- Updated
- 2026-11-02
OSVUSN-5187-1 No score
glances vulnerability
It was discovered that Glances incorrectly parsed untrusted XML data due to usage of xmlrpclib. An attacker could possibly use this to perform an External Entity (XXE) Injection and cause the host system to crash.
- Record
USN-5187-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
glancesPyPI |
before 3.2.1 | 3.2.1 |
glancesDebian:12 |
before 3.2.3.1+dfsg-1 | 3.2.3.1+dfsg-1 |
glancesDebian:13 |
before 3.2.3.1+dfsg-1 | 3.2.3.1+dfsg-1 |
glancesDebian:14 |
before 3.2.3.1+dfsg-1 | 3.2.3.1+dfsg-1 |
glancesPyPI |
before 3.2.1, plus listed versions 1.3.11.3.21.3.31.3.41.3.5 Show 45 moreShow less1.3.61.3.71.41.4.11.4.1.11.4.21.4.2.11.51.5.11.5.21.61.6.11.71.7.11.7.21.7.31.7.41.7.51.7.61.7.72.02.0.12.12.1.12.1.22.102.112.11.12.22.2.12.32.42.4.12.4.22.52.5.12.62.6.12.6.22.72.7.12.82.8.12.8.22.8.3 |
3.2.1 |
glancesUbuntu:Pro:16.04:LTS |
before 2.3-1ubuntu0.1~esm1, plus listed versions 2.3-1build1 |
2.3-1ubuntu0.1~esm1 |
glancesUbuntu:Pro:18.04:LTS |
before 2.11.1-3ubuntu0.1~esm1, plus listed versions 2.10-22.11.1-12.11.1-22.11.1-3 |
2.11.1-3ubuntu0.1~esm1 |
glancesUbuntu:Pro:20.04:LTS |
before 3.1.3-1ubuntu0.1~esm1, plus listed versions 3.1.0-13.1.1-13.1.3-1 |
3.1.3-1ubuntu0.1~esm1 |
python-GlancesopenSUSE:Tumbleweed From an advisory covering 6 CVEs |
before 4.5.6-1.1 | 4.5.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-23418 is a medium vulnerability (CVSS 6.3) in Glances Project Glances, published July 29, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.65%, the 76th percentile. Fixed in glances 3.2.1.
References
snyk.io/vuln/SNYK-PYTHON-GLANCES-1311807
github.com/nicolargo/glances/commit/4b87e979afdc06d98ed1b48da31e69eaa3a9fb94
github.com/nicolargo/glances/commit/85d5a6b4af31fcf785d5a61086cbbd166b40b07a
github.com/nicolargo/glances/issues/1025
github.com/nicolargo/glances/commit/9d6051be4a42f692392049fdbfc85d5dfa458b32
nvd.nist.gov/vuln/detail/CVE-2021-23418
Show 13 moreShow less
github.com/advisories/GHSA-r2mj-8wgq-73m6
github.com/pypa/advisory-database/tree/main/vulns/glances/PYSEC-2021-115.yaml
security-tracker.debian.org/tracker/CVE-2021-23418
github.com/nicolargo/glances
ubuntu.com/security/CVE-2021-23418
ubuntu.com/security/notices/USN-5187-1
cve.org/CVERecord?id=CVE-2021-23418
suse.com/security/cve/CVE-2021-23418
suse.com/security/cve/CVE-2026-62982
suse.com/security/cve/CVE-2026-68517
suse.com/security/cve/CVE-2026-68518
suse.com/security/cve/CVE-2026-68519
suse.com/security/cve/CVE-2026-68520
Left out here: 22 versions. The JSON record has them.