Every CVE Search/ Get API key

CVE-2021-23440

Prototype Pollution

7.3 HighFix available

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

2.21%Up 1.0 points since Sep 13, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.3

Prototype Pollution

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
CVE-2021-23440
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02
EUVDEUVD-2021-1976 7.3

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
EUVD-2021-1976
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-4jqc-8m5r-9rpr 7.3

Prototype Pollution in set-value

This affects the package set-value. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
GHSA-4jqc-8m5r-9rpr
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-843, CWE-1321
Updated
2026-11-02
NVD 7.3

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
CVE-2021-23440
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-843
Updated
2026-11-02
OSVAZL-45225 9.8

CVE-2021-23440 affecting package js-jquery 3.5.0-4

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
AZL-45225
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-05
OSV 9.8

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
CVE-2021-23440
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2021-23440 9.8

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
DEBIAN-CVE-2021-23440
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-4jqc-8m5r-9rpr 7.3

Prototype Pollution in set-value

This affects the package set-value. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
GHSA-4jqc-8m5r-9rpr
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-1321, CWE-843
Updated
2026-11-02
OSVUBUNTU-CVE-2021-23440 7.3

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Record
UBUNTU-CVE-2021-23440
CVSS 3.1
7.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVCLSA-2026-1782954034 No score

TuxCare security update for set-value (2 CVEs)

TuxCare rebuilt set-value to address 2 CVEs. Fixed in 2.0.0-tuxcare.1.

Record
CLSA-2026-1782954034
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
set-value-nuget
NuGet
before 2.0.0
2.0.0
set-value
npm
before 2.0.1
2.0.1
set-value
npm
4.0.0 up to 4.0.1
4.0.1
set-value
npm
3.0.0 up to 3.0.3
3.0.3
js-jquery
Azure Linux:3
through 3.5.0-4 None known
set-value
TuxCare:npm
From an advisory covering 2 CVEs
2.0.0-tuxcare.0 up to 2.0.0-tuxcare.1, plus listed versions
2.0.0
2.0.0-tuxcare.1
node-set-value
Debian:12
before 3.0.1-3
3.0.1-3
node-set-value
Debian:13
before 3.0.1-3
3.0.1-3
node-set-value
Debian:14
before 3.0.1-3
3.0.1-3
node-set-value
Ubuntu:18.04:LTS
All versions, plus listed versions
0.4.0-1
None known
Show 6 moreShow less
Affected packages
PackageAffectedFixed
node-set-value
Ubuntu:20.04:LTS
All versions, plus listed versions
0.4.0-10.4.0-23.0.1-2
None known
node-set-value
Ubuntu:22.04:LTS
All versions, plus listed versions
3.0.1-23.0.1-34.1.0-24.1.0+~4.0.1-1
None known
node-set-value
Ubuntu:24.04:LTS
All versions, plus listed versions
4.1.0+~4.0.1-2
None known
node-set-value
Ubuntu:25.10
All versions, plus listed versions
4.1.0+~4.0.1-2
None known
node-set-value
Ubuntu:26.10
All versions, plus listed versions
4.1.0+~4.0.3-1
None known
node-set-value
Ubuntu:26.04:LTS
All versions, plus listed versions
4.1.0+~4.0.1-24.1.0+~4.0.3-1
None known

History

History
RecordedChangedSources
affected
factsOSV
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-23440 is a high vulnerability (CVSS 7.3) in Set-value Project Set-value, published September 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in set-value-nuget 2.0.0.

References

Show 9 moreShow less
MoveEnter Open