Every CVE Search/ Get API key

CVE-2021-23520

Arbitrary File Write via Archive Extraction (Zip Slip)

5.5 MediumFix available

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.09%Up 0.3 points since Feb 1, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.5

Arbitrary File Write via Archive Extraction (Zip Slip)

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
CVE-2021-23520
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Updated
2026-11-02
EUVDEUVD-2021-10487 5.5

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
EUVD-2021-10487
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-qpj6-xj62-7c95 No score

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive...

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
GHSA-qpj6-xj62-7c95
Weakness
CWE-22
Updated
2026-11-02
NVD 5.5

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
CVE-2021-23520
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-22
Updated
2026-11-02
OSV 9.8

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
CVE-2021-23520
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-23520 9.8

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
DEBIAN-CVE-2021-23520
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-23520 5.5

The package juce-framework/juce before 6.1.5 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) via the ZipFile::uncompressEntry function in juce_ZipFile.cpp. This vulnerability is triggered when the archive is extracted upon calling uncompressTo() on a ZipFile object.

Record
UBUNTU-CVE-2021-23520
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
juce
Debian:12
before 6.1.5~ds0-1
6.1.5~ds0-1
juce
Debian:13
before 6.1.5~ds0-1
6.1.5~ds0-1
juce
Debian:14
before 6.1.5~ds0-1
6.1.5~ds0-1
juce
Ubuntu:16.04:LTS
All versions, plus listed versions
4.1.0+repack-3
None known
juce
Ubuntu:18.04:LTS
All versions, plus listed versions
4.3.0~repack-15.2.0~repack-15.2.0~repack-25.2.0~repack-35.2.1~repack-15.2.1~repack-2
None known
juce
Ubuntu:20.04:LTS
All versions, plus listed versions
5.4.4~repack0-35.4.5~ds0-15.4.6~ds0-15.4.7~ds0-1
None known
juce
Ubuntu:22.04:LTS
All versions, plus listed versions
5.4.7~ds0-26.1.3~ds0-16.1.4~ds0-16.1.5~ds0-1
None known
juce
Ubuntu:24.04:LTS
All versions, plus listed versions
7.0.5+ds-17.0.5+ds-1build17.0.5+ds-1build27.0.5+ds-2
None known
juce
Ubuntu:25.10
All versions, plus listed versions
8.0.6+ds-2
None known
juce
Ubuntu:26.10
All versions, plus listed versions
8.0.12+ds-18.0.13+ds-18.0.14+ds-1
None known
juce
Ubuntu:26.04:LTS
All versions, plus listed versions
8.0.6+ds-28.0.12+ds-1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-23520 is a medium vulnerability (CVSS 5.5) in Juce, published January 31, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in juce 6.1.5~ds0-1.

References

MoveEnter Open