CVE-2021-24040
Deserialization of Untrusted Data in ParlAI
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
CVE-2021-24040- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List No score
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
CVE-2021-24040- Weakness
- CWE-502
- Updated
- 2026-11-02
EUVDEUVD-2021-0165 No score
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
EUVD-2021-0165- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mwgj-7x7j-6966 No score
Deserialization of Untrusted Data in ParlAI
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
GHSA-mwgj-7x7j-6966- Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
9.8
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
CVE-2021-24040- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVCVE-2021-39207
8.8
parlai is a framework for training and evaluating AI models on a variety of openly available dialogue datasets. In affected versions the package is vulnerable to YAML deserialization attack caused by unsafe loading which leads to Arbitary code execution. This security bug is patched by avoiding unsafe loader users should update to version above v1.1.0. If upgrading is not possible then users can change the Loader used to SafeLoader as a workaround. See commit 507d066ef432ea27d3e201da08009872a2f37725 for details.
- Record
CVE-2021-39207- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-m87f-9fvv-2mgg
5.6
Deserialization of Untrusted Data in parlai
Impact
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks.
Patches
The issue can be patched by upgrading to v1.1.0 or later. It can also be patched by replacing YAML deserialization with equivalent safe_load calls.
References
- Record
GHSA-m87f-9fvv-2mgg- CVSS 4.0
- 5.6 Medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:L - CVSS 3.1
- 8.4 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L - Weakness
- CWE-502
- Updated
- 2026-11-02
OSVGHSA-mwgj-7x7j-6966 No score
Deserialization of Untrusted Data in ParlAI
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
GHSA-mwgj-7x7j-6966- Weakness
- CWE-502
- Updated
- 2026-11-02
OSVPYSEC-2021-330 No score
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
- Record
PYSEC-2021-330- Updated
- 2026-11-02
OSVPYSEC-2021-334 No score
parlai is a framework for training and evaluating AI models on a variety of openly available dialogue datasets. In affected versions the package is vulnerable to YAML deserialization attack caused by unsafe loading which leads to Arbitary code execution. This security bug is patched by avoiding unsafe loader users should update to version above v1.1.0. If upgrading is not possible then users can change the Loader used to SafeLoader as a workaround. See commit 507d066ef432ea27d3e201da08009872a2f37725 for details.
- Record
PYSEC-2021-334- Updated
- 2026-11-02
Affected products
Affected packages
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Facebook ParlAI 1.0.0 - Deserialization of Untrusted Data in parlai | 2021-09-13 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, products | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-24040 is a critical vulnerability (CVSS 9.8) in Facebook Parlai, published September 10, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 17.4%, the 97th percentile. Fixed in parlai 1.1.0.
References
github.com/facebookresearch/ParlAI/releases/tag/v1.1.0
github.com/facebookresearch/ParlAI/security/advisories/GHSA-m87f-9fvv-2mgg
packetstormsecurity.com/files/164136/Facebook-ParlAI-1.0.0-Code-Execution-Deserialization.html
nvd.nist.gov/vuln/detail/CVE-2021-24040
github.com/facebookresearch/ParlAI/pull/3402
github.com/facebookresearch/ParlAI/pull/3429
Show 7 moreShow less
github.com/facebookresearch/ParlAI/commit/4374fa2aba383db6526ab36e939eb1cf8ef99879
github.com/advisories/GHSA-mwgj-7x7j-6966
github.com/facebookresearch/ParlAI/commit/507d066ef432ea27d3e201da08009872a2f37725
nvd.nist.gov/vuln/detail/CVE-2021-39207
github.com/facebookresearch/ParlAI
github.com/pypa/advisory-database/tree/main/vulns/parlai/PYSEC-2021-330.yaml
github.com/pypa/advisory-database/tree/main/vulns/parlai/PYSEC-2021-334.yaml