CVE-2021-24323
Woocommerce < 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.8
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
- Record
CVE-2021-24323- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Woocommerce < 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
- Record
CVE-2021-24323- Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-4599 No score
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
- Record
EUVD-2022-4599- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mp46-7x6q-f28m
4.8
Woocommerce Cross-site Scripting via Additional tax classes field when taxes are enabled
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
- Record
GHSA-mp46-7x6q-f28m- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
4.8
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
- Record
CVE-2021-24323- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-mp46-7x6q-f28m
4.8
Woocommerce Cross-site Scripting via Additional tax classes field when taxes are enabled
When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
- Record
GHSA-mp46-7x6q-f28m- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
woocommerce/woocommercePackagist |
before 5.2.0 | 5.2.0 |
woocommerce/woocommercePackagist |
before 5.2.0, plus listed versions 2.6.102.6.112.6.122.6.132.6.14 Show 45 moreShow less2.6.32.6.42.6.52.6.62.6.72.6.82.6.92.7.0-RC12.7.0-beta-12.7.0-beta-22.7.0-beta-32.7.0-beta-43.0.03.0.0-rc.13.0.0-rc.23.0.13.0.23.0.33.0.43.0.53.0.63.0.73.0.83.0.93.1.03.1.0-beta-13.1.0-beta.23.1.0-rc.13.1.0-rc.23.1.13.1.23.2.03.2.0-beta.13.2.0-beta.23.2.0-rc.23.2.13.2.23.2.33.2.43.2.53.2.63.3.03.3.0-beta.13.3.0-beta.23.3.0-rc.1 |
5.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-24323 is a medium vulnerability (CVSS 4.8) in Automattic Woocommerce, published May 17, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in woocommerce/woocommerce 5.2.0.
References
Left out here: 187 versions. The JSON record has them.