Every CVE Search/ Get API key

CVE-2021-25925

Cross-site scripting in SiCKRAGE

5.4 MediumFix available

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.66%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
CVE-2021-25925
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List 5.4

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
CVE-2021-25925
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-0242 5.4

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
EUVD-2021-0242
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-rmp7-f2vp-3rq4 5.4

Cross-site scripting in SiCKRAGE

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
GHSA-rmp7-f2vp-3rq4
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
CVE-2021-25925
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-rmp7-f2vp-3rq4 5.4

Cross-site scripting in SiCKRAGE

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
GHSA-rmp7-f2vp-3rq4
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2021-147 No score

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Record
PYSEC-2021-147
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sickrage
PyPI
4.2.0 to 10.0.11.dev1
10.0.11.dev2
sickrage
PyPI
4.2.0 up to 10.0.11.dev2, plus listed versions
10.0.010.0.0.dev1010.0.0.dev1110.0.0.dev1210.0.0.dev13
Show 45 moreShow less
10.0.0.dev1410.0.0.dev1510.0.0.dev1610.0.0.dev1710.0.0.dev1810.0.0.dev1910.0.0.dev2010.0.0.dev2110.0.0.dev2210.0.0.dev2310.0.0.dev2410.0.0.dev2510.0.0.dev2610.0.0.dev2710.0.0.dev2810.0.0.dev2910.0.0.dev310.0.0.dev3010.0.0.dev3110.0.0.dev3310.0.0.dev3410.0.0.dev3510.0.0.dev410.0.0.dev510.0.0.dev610.0.0.dev710.0.0.dev810.0.0.dev910.0.110.0.1.dev110.0.1010.0.10.dev110.0.10.dev210.0.11.dev110.0.210.0.2.dev110.0.310.0.3.dev110.0.410.0.4.dev110.0.4.dev210.0.4.dev310.0.4.dev410.0.510.0.5.dev1
10.0.11.dev2
sickrage
PyPI
4.2.0 up to 10.0.12.dev1, plus listed versions
10.0.010.0.0.dev1010.0.0.dev1110.0.0.dev1210.0.0.dev13
Show 45 moreShow less
10.0.0.dev1410.0.0.dev1510.0.0.dev1610.0.0.dev1710.0.0.dev1810.0.0.dev1910.0.0.dev2010.0.0.dev2110.0.0.dev2210.0.0.dev2310.0.0.dev2410.0.0.dev2510.0.0.dev2610.0.0.dev2710.0.0.dev2810.0.0.dev2910.0.0.dev310.0.0.dev3010.0.0.dev3110.0.0.dev3310.0.0.dev3410.0.0.dev3510.0.0.dev410.0.0.dev510.0.0.dev610.0.0.dev710.0.0.dev810.0.0.dev910.0.110.0.1.dev110.0.1010.0.10.dev110.0.10.dev210.0.1110.0.11.dev110.0.11.dev210.0.210.0.2.dev110.0.310.0.3.dev110.0.410.0.4.dev110.0.4.dev210.0.4.dev310.0.4.dev4
10.0.12.dev1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-25925 is a medium vulnerability (CVSS 5.4) in Sickrage, published April 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.66%, the 51st percentile. Fixed in sickrage 10.0.11.dev2.

References

This page doesn't list everything

Left out here: 2,088 versions. The JSON record has them.

MoveEnter Open