Every CVE Search/ Get API key

CVE-2021-25926

Cross-site scripting in sickrage

6.1 MediumFix available

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.82%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
CVE-2021-25926
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List 6.1

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
CVE-2021-25926
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2021-0243 6.1

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
EUVD-2021-0243
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-x823-j7c4-vpc5 6.1

Cross-site scripting in sickrage

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
GHSA-x823-j7c4-vpc5
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
CVE-2021-25926
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-x823-j7c4-vpc5 6.1

Cross-site scripting in sickrage

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
GHSA-x823-j7c4-vpc5
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2021-148 No score

In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being validated properly in the quicksearch feature. Therefore, an attacker can steal a user's sessionID to masquerade as a victim user, to carry out any actions in the context of the user.

Record
PYSEC-2021-148
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sickrage
PyPI
9.3.54 to 10.0.11.dev1
10.0.11.dev2
sickrage
PyPI
9.3.54 up to 10.0.11.dev2, plus listed versions
10.0.010.0.0.dev1010.0.0.dev1110.0.0.dev1210.0.0.dev13
Show 45 moreShow less
10.0.0.dev1410.0.0.dev1510.0.0.dev1610.0.0.dev1710.0.0.dev1810.0.0.dev1910.0.0.dev2010.0.0.dev2110.0.0.dev2210.0.0.dev2310.0.0.dev2410.0.0.dev2510.0.0.dev2610.0.0.dev2710.0.0.dev2810.0.0.dev2910.0.0.dev310.0.0.dev3010.0.0.dev3110.0.0.dev3310.0.0.dev3410.0.0.dev3510.0.0.dev410.0.0.dev510.0.0.dev610.0.0.dev710.0.0.dev810.0.0.dev910.0.110.0.1.dev110.0.1010.0.10.dev110.0.10.dev210.0.11.dev110.0.210.0.2.dev110.0.310.0.3.dev110.0.410.0.4.dev110.0.4.dev210.0.4.dev310.0.4.dev410.0.510.0.5.dev1
10.0.11.dev2
sickrage
PyPI
9.3.55 up to 10.0.12.dev1, plus listed versions
10.0.010.0.0.dev1010.0.0.dev1110.0.0.dev1210.0.0.dev13
Show 45 moreShow less
10.0.0.dev1410.0.0.dev1510.0.0.dev1610.0.0.dev1710.0.0.dev1810.0.0.dev1910.0.0.dev2010.0.0.dev2110.0.0.dev2210.0.0.dev2310.0.0.dev2410.0.0.dev2510.0.0.dev2610.0.0.dev2710.0.0.dev2810.0.0.dev2910.0.0.dev310.0.0.dev3010.0.0.dev3110.0.0.dev3310.0.0.dev3410.0.0.dev3510.0.0.dev410.0.0.dev510.0.0.dev610.0.0.dev710.0.0.dev810.0.0.dev910.0.110.0.1.dev110.0.1010.0.10.dev110.0.10.dev210.0.1110.0.11.dev110.0.11.dev210.0.210.0.2.dev110.0.310.0.3.dev110.0.410.0.4.dev110.0.4.dev210.0.4.dev310.0.4.dev4
10.0.12.dev1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-25926 is a medium vulnerability (CVSS 6.1) in Sickrage, published April 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.82%, the 57th percentile. Fixed in sickrage 10.0.11.dev2.

References

This page doesn't list everything

Left out here: 1,299 versions. The JSON record has them.

MoveEnter Open