CVE-2021-25959
OpenCRX - Reflected Cross-Site Scripting in Password Reset Functionality
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.1
OpenCRX - Reflected Cross-Site Scripting in Password Reset Functionality
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
- Record
CVE-2021-25959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2021-2111
6.1
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
- Record
EUVD-2021-2111- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rwh9-8xx8-4wfm
6.1
Cross-site Scripting in OpenCRX
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
- Record
GHSA-rwh9-8xx8-4wfm- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
6.1
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
- Record
CVE-2021-25959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
- Record
CVE-2021-25959- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-rwh9-8xx8-4wfm
6.1
Cross-site Scripting in OpenCRX
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
- Record
GHSA-rwh9-8xx8-4wfm- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.opencrx:opencrx-coreMaven |
4.0.0 up to 5.2.0 | 5.2.0 |
org.opencrx:opencrx-core-modelsMaven |
4.0.0 up to 5.2.0 | 5.2.0 |
org.opencrx:opencrx-core-configMaven |
4.0.0 up to 5.2.0 | 5.2.0 |
org.opencrx:opencrx-clientMaven |
4.0.0 up to 5.2.0 | 5.2.0 |
org.opencrx:opencrx-gradleMaven |
4.0.0 up to 5.2.0 | 5.2.0 |
org.opencrx:opencrx-coreMaven |
4.0.0 up to 5.2.0, plus listed versions 4.3-alpha-14.3-alpha-104.3-alpha-114.3-alpha-24.3-alpha-3 Show 10 moreShow less4.3-alpha-44.3-alpha-54.3-alpha-64.3-alpha-74.3-alpha-84.3-alpha-94.3.05.0.05.0.15.1.0 |
5.2.0 |
org.opencrx:opencrx-core-modelsMaven |
4.0.0 up to 5.2.0, plus listed versions 4.3-alpha-104.3-alpha-114.3-alpha-94.3.05.0.05.0.15.1.0 |
5.2.0 |
org.opencrx:opencrx-core-configMaven |
4.0.0 up to 5.2.0, plus listed versions 4.3.05.0.05.0.15.1.0 |
5.2.0 |
org.opencrx:opencrx-clientMaven |
4.0.0 up to 5.2.0, plus listed versions 4.3-alpha-14.3-alpha-104.3-alpha-114.3-alpha-24.3-alpha-3 Show 10 moreShow less4.3-alpha-44.3-alpha-54.3-alpha-64.3-alpha-74.3-alpha-84.3-alpha-94.3.05.0.05.0.15.1.0 |
5.2.0 |
org.opencrx:opencrx-gradleMaven |
4.0.0 up to 5.2.0, plus listed versions 4.3-alpha-14.3-alpha-104.3-alpha-114.3-alpha-24.3-alpha-3 Show 10 moreShow less4.3-alpha-44.3-alpha-54.3-alpha-64.3-alpha-74.3-alpha-84.3-alpha-94.3.05.0.05.0.15.1.0 |
5.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-25959 is a medium vulnerability (CVSS 6.1) in Opencrx, published September 29, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in org.opencrx:opencrx-core 5.2.0.