CVE-2021-25973
Publify - Improper Authorization Leads to Guest Signup Restriction Bypass
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
Publify - Improper Authorization Leads to Guest Signup Restriction Bypass
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
- Record
CVE-2021-25973- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2021-2410
6.5
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
- Record
EUVD-2021-2410- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x24j-87x9-jvv5
6.5
Publify `guest` role users can self-register even when the admin does not allow it
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. guest role users can self-register even when the admin does not allow it. This happens due to front-end restriction only.
- Record
GHSA-x24j-87x9-jvv5- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-285, CWE-669, CWE-863
- Updated
- 2026-11-02
NVD
6.5
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
- Record
CVE-2021-25973- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Weakness
- CWE-285, CWE-669
- Updated
- 2026-11-02
OSV
6.5
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
- Record
CVE-2021-25973- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-x24j-87x9-jvv5
6.5
Publify `guest` role users can self-register even when the admin does not allow it
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. guest role users can self-register even when the admin does not allow it. This happens due to front-end restriction only.
- Record
GHSA-x24j-87x9-jvv5- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-285, CWE-669, CWE-863
- Updated
- 2026-11-02
OSVBIT-publify-2021-25973 No score
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
- Record
BIT-publify-2021-25973- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
9.0.0.pre1 up to 9.2.5 | 9.2.5 |
publifyBitnami |
9.0.0 up to 9.2.4 | 9.2.4 |
publify_coreRubyGems |
9.0.0.pre1 up to 9.2.5, plus listed versions 9.0.09.0.0.pre29.0.0.pre39.0.0.pre49.0.0.pre5 Show 8 moreShow less9.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.4 |
9.2.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-25973 is a medium vulnerability (CVSS 6.5) in Publify Project Publify, published November 2, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in publify_core 9.2.5.
References
github.com/publify/publify/commit/3447e0241e921b65f6eb1090453d8ea73e98387e
whitesourcesoftware.com/vulnerability-database/CVE-2021-25973
nvd.nist.gov/vuln/detail/CVE-2021-25973
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2021-25973.yml
github.com/advisories/GHSA-x24j-87x9-jvv5
github.com/publify/publify