Every CVE Search/ Get API key

CVE-2021-26313

AMD Speculative Code Store Bypass

5.5 MediumFix available

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.33%Down 1.1 points since Jun 10, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
CVE-2021-26313
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-208, CWE-203
Updated
2026-11-02
CVE List No score

AMD Speculative Code Store Bypass

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
CVE-2021-26313
Weakness
CWE-208
Updated
2026-11-02
EUVDEUVD-2021-13119 No score

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
EUVD-2021-13119
Updated
2026-11-03
GitHub AdvisoriesGHSA-vj56-jg6h-3gpr 5.5

Potential speculative code store bypass in all supported CPU products, in conjunction with...

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
GHSA-vj56-jg6h-3gpr
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-203, CWE-668
Updated
2026-11-02
OSV 5.5

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
CVE-2021-26313
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-26313 5.5

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
DEBIAN-CVE-2021-26313
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2021-26313 5.5

Potential speculative code store bypass in all supported CPU products, in conjunction with software vulnerabilities relating to speculative execution of overwritten instructions, may cause an incorrect speculation and could result in data leakage.

Record
UBUNTU-CVE-2021-26313
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
xen
Debian:12
before 4.14.2+25-gb6a8c4f72d-1
4.14.2+25-gb6a8c4f72d-1
xen
Debian:13
before 4.14.2+25-gb6a8c4f72d-1
4.14.2+25-gb6a8c4f72d-1
xen
Debian:14
before 4.14.2+25-gb6a8c4f72d-1
4.14.2+25-gb6a8c4f72d-1
xen
Debian:10
From an advisory covering 4 CVEs
before 4.11.4+107-gef32c7afa2-1, plus listed versions
4.11.1+92-g6c33308a8d-24.11.3+24-g14b62ab3e5-14.11.3+24-g14b62ab3e5-1~deb10u14.11.4+24-gddaaccbbab-14.11.4+24-gddaaccbbab-1~deb10u1
Show 5 moreShow less
4.11.4+37-g3263f257ca-14.11.4+57-g41a822c392-14.11.4+57-g41a822c392-24.11.4+99-g8bce4698f6-14.11.4-1
4.11.4+107-gef32c7afa2-1
xen
Ubuntu:16.04:LTS
All versions, plus listed versions
4.5.1-0ubuntu14.5.1-0ubuntu24.6.0-1ubuntu14.6.0-1ubuntu24.6.0-1ubuntu4
Show 7 moreShow less
4.6.0-1ubuntu4.14.6.0-1ubuntu4.24.6.0-1ubuntu4.34.6.5-0ubuntu14.6.5-0ubuntu1.14.6.5-0ubuntu1.24.6.5-0ubuntu1.4
None known
xen
Ubuntu:18.04:LTS
All versions, plus listed versions
4.9.0-0ubuntu34.9.0-0ubuntu44.9.2-0ubuntu1
None known
xen
Ubuntu:20.04:LTS
All versions, plus listed versions
4.9.2-0ubuntu24.9.2-0ubuntu64.9.2-0ubuntu74.11.3+24-g14b62ab3e5-1ubuntu14.11.3+24-g14b62ab3e5-1ubuntu24.11.3+24-g14b62ab3e5-1ubuntu2.24.11.3+24-g14b62ab3e5-1ubuntu2.3
None known
xen
Ubuntu:22.04:LTS
All versions, plus listed versions
4.11.4+24-gddaaccbbab-1ubuntu24.16.0-1~ubuntu24.16.0-1~ubuntu2.1
None known
xen
Ubuntu:24.04:LTS
All versions, plus listed versions
4.17.2-14.17.2+55-g0b56bed864-14.17.2+76-ge1f9cb16e2-14.17.2+76-ge1f9cb16e2-1ubuntu14.17.3+10-g091466ba55-14.17.3+10-g091466ba55-1.1ubuntu24.17.3+10-g091466ba55-1.1ubuntu3
None known
xen
Ubuntu:25.10
All versions, plus listed versions
4.20.0-1ubuntu14.20.0+68-g35cb38b222-1
None known
xen
Ubuntu:26.10
All versions, plus listed versions
4.20.2+7-g1badcf5035-2build24.20.2+37-g61ff35323e-1ubuntu14.20.3+127-gc42374a105-1
None known
xen
Ubuntu:26.04:LTS
All versions, plus listed versions
4.20.0+68-g35cb38b222-14.20.2+7-g1badcf5035-24.20.2+7-g1badcf5035-2build2
None known

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-26313 is a medium vulnerability (CVSS 5.5) in Amd All Supported Processors, published June 9, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in xen 4.14.2+25-gb6a8c4f72d-1.

References

Show 8 moreShow less
MoveEnter Open