CVE-2021-26642
XpressEngine file upload vulnerability
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
XpressEngine file upload vulnerability
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
- Record
CVE-2021-26642- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-434
- Updated
- 2026-11-02
EUVDEUVD-2023-0413
8.8
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
- Record
EUVD-2023-0413- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8r5j-22j5-w4cm
9.8
XpressEngine vulnerable to Unrestricted Upload of File with Dangerous Type
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
- Record
GHSA-8r5j-22j5-w4cm- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-434
- Updated
- 2026-11-02
NVD
8.8
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
- Record
CVE-2021-26642- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-434
- Updated
- 2026-11-02
OSV
9.8
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
- Record
CVE-2021-26642- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-8r5j-22j5-w4cm
9.8
XpressEngine vulnerable to Unrestricted Upload of File with Dangerous Type
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
- Record
GHSA-8r5j-22j5-w4cm- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-434
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
xpressengine/xpressenginePackagist |
before 3.0.15 | 3.0.15 |
xpressengine/xpressenginePackagist |
before 3.0.15, plus listed versions 3.0.03.0.0-beta3.0.0-beta.103.0.0-beta.113.0.0-beta.12 Show 45 moreShow less3.0.0-beta.133.0.0-beta.143.0.0-beta.153.0.0-beta.163.0.0-beta.173.0.0-beta.183.0.0-beta.193.0.0-beta.23.0.0-beta.203.0.0-beta.213.0.0-beta.223.0.0-beta.233.0.0-beta.243.0.0-beta.253.0.0-beta.263.0.0-beta.273.0.0-beta.283.0.0-beta.293.0.0-beta.33.0.0-beta.303.0.0-beta.43.0.0-beta.53.0.0-beta.63.0.0-beta.73.0.0-beta.83.0.0-beta.93.0.0-rc.13.0.0-rc.23.0.0-rc.33.0.0-rc.43.0.0-rc.53.0.0-rc.63.0.0-rc.73.0.0-rc.83.0.13.0.103.0.113.0.123.0.133.0.143.0.23.0.33.0.43.0.53.0.6 |
3.0.15 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-26642 is a high vulnerability (CVSS 8.8) in Xpressengine, published January 20, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.21%, the 68th percentile. Fixed in xpressengine/xpressengine 3.0.15.
References
Left out here: 3 versions. The JSON record has them.