Every CVE Search/ Get API key

CVE-2021-27915

XSS Cross-site Scripting Stored (XSS) - Description field

7.6 HighFix available

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
Low

Exploit likelihood

0.62%Up 0.6 points since Sep 18, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.6

XSS Cross-site Scripting Stored (XSS) - Description field

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Record
CVE-2021-27915
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-80
Updated
2026-11-02
EUVDEUVD-2024-1069 7.6

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Record
EUVD-2024-1069
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-2rc5-2755-v422 8.6

Mautic vulnerable to stored cross-site scripting in description field

Impact

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Patches

Update to 4.4.12

Workarounds

None

References

If you have any questions or comments about this advisory:

Email us at [email protected]

Record
GHSA-2rc5-2755-v422
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-79, CWE-80
Updated
2026-11-02
NVD 7.6

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Record
CVE-2021-27915
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
CVSS 3.1
9.0 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weakness
CWE-80, CWE-79
Updated
2026-11-02
OSV 9.0

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Record
CVE-2021-27915
CVSS 3.1
9.0 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-2rc5-2755-v422 8.6

Mautic vulnerable to stored cross-site scripting in description field

Impact

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Patches

Update to 4.4.12

Workarounds

None

References

If you have any questions or comments about this advisory:

Email us at [email protected]

Record
GHSA-2rc5-2755-v422
CVSS 4.0
8.6 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
7.6 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
Weakness
CWE-79, CWE-80
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mautic/core
Packagist
1.0.0-beta2 up to 4.4.12
4.4.12
mautic/core
Packagist
1.0.0-beta2 up to 4.4.12, plus listed versions
1.0.01.0.0-beta31.0.0-beta41.0.0-rc11.0.0-rc2
Show 45 moreShow less
1.0.0-rc31.0.0-rc41.0.11.0.21.0.31.0.41.0.51.1.01.1.11.1.21.1.31.2.01.2.0-beta11.2.11.2.21.2.31.2.41.3.01.3.11.4.01.4.12.0.02.0.12.1.02.1.12.10.02.10.0-beta2.10.12.11.02.11.0-beta2.12.02.12.0-beta2.12.12.12.1-beta2.12.22.12.2-beta2.13.02.13.0-beta2.13.12.14.02.14.0-beta2.14.12.14.1-beta2.14.22.14.2-beta
4.4.12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-27915 is a high vulnerability (CVSS 7.6) in Acquia Mautic, published April 11, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 49th percentile. Fixed in mautic/core 4.4.12.

References

This page doesn't list everything

Left out here: 97 versions. The JSON record has them.

MoveEnter Open