Every CVE Search/ Get API key

CVE-2021-28145

Concrete CMS Cross-site Scripting via Survey Blocks

5.4 MediumFix available

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct XSS attacks via a crafted survey block. This requires at least Editor privileges.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.86%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct XSS attacks via a crafted survey block. This requires at least Editor privileges.

Record
CVE-2021-28145
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct XSS attacks via a crafted survey block. This requires at least Editor privileges.

Record
CVE-2021-28145
Updated
2026-11-02
EUVDEUVD-2022-2902 No score

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct XSS attacks via a crafted survey block. This requires at least Editor privileges.

Record
EUVD-2022-2902
Updated
2026-11-03
GitHub AdvisoriesGHSA-7388-7vq2-m4f4 5.4

Concrete CMS Cross-site Scripting via Survey Blocks

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct Cross-site Scripting (XSS) attacks via a crafted survey block. This requires at least Editor privileges.

Record
GHSA-7388-7vq2-m4f4
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct XSS attacks via a crafted survey block. This requires at least Editor privileges.

Record
CVE-2021-28145
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-7388-7vq2-m4f4 5.4

Concrete CMS Cross-site Scripting via Survey Blocks

Concrete CMS (formerly concrete5) before 8.5.5 allows remote authenticated users to conduct Cross-site Scripting (XSS) attacks via a crafted survey block. This requires at least Editor privileges.

Record
GHSA-7388-7vq2-m4f4
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
concrete5/concrete5
Packagist
before 8.5.5
8.5.5
concrete5/concrete5
Packagist
before 8.5.5, plus listed versions
8.08.0.18.0.28.0.38.1.0
Show 21 moreShow less
8.2.08.2.0RC28.2.18.3.08.3.18.3.28.4.08.4.0RC38.4.0RC48.4.18.4.28.4.38.4.48.4.58.5.08.5.0RC18.5.0RC28.5.18.5.28.5.38.5.4
8.5.5

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-28145 is a medium vulnerability (CVSS 5.4) in Concretecms Concrete Cms, published March 18, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in concrete5/concrete5 8.5.5.

References

MoveEnter Open