CVE-2021-28275
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the...
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
CVE-2021-28275- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-704
- Updated
- 2026-11-02
CVE List No score
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
CVE-2021-28275- Updated
- 2026-11-02
EUVDEUVD-2021-14964 No score
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
EUVD-2021-14964- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-67w2-vvm4-fjr9
5.5
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the...
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
GHSA-67w2-vvm4-fjr9- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-77, CWE-704
- Updated
- 2026-11-02
OSV
5.5
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
CVE-2021-28275- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-28275
5.5
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
DEBIAN-CVE-2021-28275- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-28275
5.5
A Denial of Service vulnerability exists in jhead 3.04 and 3.05 due to a wild address read in the Get16u function in exif.c in will cause segmentation fault via a crafted_file.
- Record
UBUNTU-CVE-2021-28275- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-6110-1 No score
Jhead vulnerabilities
It was discovered that Jhead did not properly handle certain crafted Canon images when processing them. An attacker could possibly use this issue to crash Jhead, resulting in a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2021-3496)
It was discovered that Jhead did not properly handle certain crafted images when printing Canon-specific information. An attacker could possibly use this issue to crash Jhead, resulting in a denial of service. This issue only affected Ubuntu 20.04. (CVE-2021-28275)
It was discovered that Jhead did not properly handle certain crafted images when removing unknown sections. An attacker could possibly use this issue to crash Jhead, resulting in a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2021-28277)
Kyle Brown discovered that Jhead did not properly handle certain crafted images when editing their comments. An attacker could possibly use this to crash Jhead, resulting in a denial of service. (LP: #2020068)
- Record
USN-6110-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
jheadDebian:12 |
before 1:3.06.0.1-2 | 1:3.06.0.1-2 |
jheadDebian:13 |
before 1:3.06.0.1-2 | 1:3.06.0.1-2 |
jheadDebian:14 |
before 1:3.06.0.1-2 | 1:3.06.0.1-2 |
jheadUbuntu:Pro:20.04:LTS |
before 1:3.04-1ubuntu0.2+esm1, plus listed versions 1:3.03-31:3.04-11:3.04-1ubuntu0.11:3.04-1ubuntu0.2 |
1:3.04-1ubuntu0.2+esm1 |
jheadUbuntu:Pro:14.04:LTS From an advisory covering 3 CVEs |
before 1:2.97-1+deb8u2ubuntu0.1~esm3, plus listed versions 1:2.97-11:2.97-1+deb8u1build0.14.04.11:2.97-1+deb8u2build0.14.04.1~esm11:2.97-1+deb8u2ubuntu0.1~esm11:2.97-1+deb8u2ubuntu0.1~esm2 |
1:2.97-1+deb8u2ubuntu0.1~esm3 |
jheadUbuntu:Pro:16.04:LTS From an advisory covering 3 CVEs |
before 1:3.00-4+deb9u1ubuntu0.1~esm3, plus listed versions 1:3.00-11:3.00-21:3.00-31:3.00-4+deb9u1build0.16.04.11:3.00-4+deb9u1ubuntu0.1~esm11:3.00-4+deb9u1ubuntu0.1~esm2 |
1:3.00-4+deb9u1ubuntu0.1~esm3 |
jheadUbuntu:Pro:18.04:LTS From an advisory covering 3 CVEs |
before 1:3.00-8~ubuntu0.2+esm1, plus listed versions 1:3.00-41:3.00-51:3.00-61:3.00-8~build0.18.04.11:3.00-8~ubuntu0.11:3.00-8~ubuntu0.2 |
1:3.00-8~ubuntu0.2+esm1 |
jheadUbuntu:Pro:20.04:LTS From an advisory covering 3 CVEs |
before 1:3.04-1ubuntu0.2+esm1, plus listed versions 1:3.03-31:3.04-11:3.04-1ubuntu0.11:3.04-1ubuntu0.2 |
1:3.04-1ubuntu0.2+esm1 |
jheadUbuntu:Pro:22.04:LTS From an advisory covering 3 CVEs |
before 1:3.06.0.1-2ubuntu0.22.04.1+esm1, plus listed versions 1:3.04-61:3.06.0.1-21:3.06.0.1-2ubuntu0.22.04.1 |
1:3.06.0.1-2ubuntu0.22.04.1+esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-28275 is a medium vulnerability (CVSS 5.5) in Jhead Project Jhead, published March 23, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.66%, the 51st percentile. Fixed in jhead 1:3.06.0.1-2.