Every CVE Search/ Get API key

CVE-2021-28278

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the...

7.8 HighFix available

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.87%Unchanged since Mar 24, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
CVE-2021-28278
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
CVE-2021-28278
Updated
2026-11-02
EUVDEUVD-2021-14967 No score

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
EUVD-2021-14967
Updated
2026-11-03
GitHub AdvisoriesGHSA-cf7f-2rx6-pw73 7.8

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the...

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
GHSA-cf7f-2rx6-pw73
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
CVE-2021-28278
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-28278 7.8

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
DEBIAN-CVE-2021-28278
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-28278 7.8

A Heap-based Buffer Overflow vulnerability exists in jhead 3.04 and 3.05 via the RemoveSectionType function in jpgfile.c.

Record
UBUNTU-CVE-2021-28278
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-6098-1 No score

Jhead vulnerabilities

It was discovered that Jhead did not properly handle certain crafted images while processing the JFIF markers. An attacker could cause Jhead to crash. This issue only affected Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, and Ubuntu 18.04 LTS. (CVE-2019-19035)

It was discovered that Jhead did not properly handle certain crafted images while processing longitude tags. An attacker could cause Jhead to crash. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2019-1010301)

It was discovered that Jhead did not properly handle certain crafted images while processing IPTC data. An attacker could cause Jhead to crash. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2019-1010302)

Binbin Li discovered that Jhead did not properly handle certain crafted images while processing the DQT data. An attacker could cause Jhead to crash. (CVE-2020-6624)

Binbin Li discovered that Jhead did not properly handle certain crafted images while processing longitude data. An attacker could cause Jhead to crash. (CVE-2020-6625)

Feng Zhao Yang discovered that Jhead did not properly handle certain crafted images while reading JPEG sections. An attacker could cause Jhead to crash. (CVE-2020-26208)

It was discovered that Jhead did not properly handle certain crafted images while processing Canon images. An attacker could cause Jhead to crash. (CVE-2021-28276)

It was discovered that Jhead did not properly handle certain crafted images when removing a certain type of sections. An attacker could cause Jhead to crash. (CVE-2021-28278)

Record
USN-6098-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jhead
Debian:12
before 1:3.06.0.1-2
1:3.06.0.1-2
jhead
Debian:13
before 1:3.06.0.1-2
1:3.06.0.1-2
jhead
Debian:14
before 1:3.06.0.1-2
1:3.06.0.1-2
jhead
Ubuntu:Pro:14.04:LTS
before 1:2.97-1+deb8u2ubuntu0.1~esm1, plus listed versions
1:2.97-11:2.97-1+deb8u1build0.14.04.11:2.97-1+deb8u2build0.14.04.1~esm1
1:2.97-1+deb8u2ubuntu0.1~esm1
jhead
Ubuntu:Pro:16.04:LTS
before 1:3.00-4+deb9u1ubuntu0.1~esm1, plus listed versions
1:3.00-11:3.00-21:3.00-31:3.00-4+deb9u1build0.16.04.1
1:3.00-4+deb9u1ubuntu0.1~esm1
jhead
Ubuntu:18.04:LTS
before 1:3.00-8~ubuntu0.1, plus listed versions
1:3.00-41:3.00-51:3.00-61:3.00-8~build0.18.04.1
1:3.00-8~ubuntu0.1
jhead
Ubuntu:20.04:LTS
before 1:3.04-1ubuntu0.1, plus listed versions
1:3.03-31:3.04-1
1:3.04-1ubuntu0.1
jhead
Ubuntu:Pro:14.04:LTS
From an advisory covering 8 CVEs
before 1:2.97-1+deb8u2ubuntu0.1~esm1, plus listed versions
1:2.97-11:2.97-1+deb8u1build0.14.04.11:2.97-1+deb8u2build0.14.04.1~esm1
1:2.97-1+deb8u2ubuntu0.1~esm1
jhead
Ubuntu:Pro:16.04:LTS
From an advisory covering 8 CVEs
before 1:3.00-4+deb9u1ubuntu0.1~esm1, plus listed versions
1:3.00-11:3.00-21:3.00-31:3.00-4+deb9u1build0.16.04.1
1:3.00-4+deb9u1ubuntu0.1~esm1
jhead
Ubuntu:18.04:LTS
From an advisory covering 8 CVEs
before 1:3.00-8~ubuntu0.1, plus listed versions
1:3.00-41:3.00-51:3.00-61:3.00-8~build0.18.04.1
1:3.00-8~ubuntu0.1
jhead
Ubuntu:20.04:LTS
From an advisory covering 8 CVEs
before 1:3.04-1ubuntu0.1, plus listed versions
1:3.03-31:3.04-1
1:3.04-1ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-28278 is a high vulnerability (CVSS 7.8) in Jhead Project Jhead, published March 23, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 58th percentile. Fixed in jhead 1:3.06.0.1-2.

References

Show 10 moreShow less
MoveEnter Open