CVE-2021-28302
A stack overflow in pupnp 1.16.1 can cause the denial of service through the Parser_parseDocument...
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
CVE-2021-28302- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-770
- Updated
- 2026-11-02
CVE List No score
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
CVE-2021-28302- Updated
- 2026-11-02
EUVDEUVD-2021-14991 No score
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
EUVD-2021-14991- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-24m8-vm8v-rrfv
7.5
A stack overflow in pupnp 1.16.1 can cause the denial of service through the Parser_parseDocument...
A stack overflow in pupnp 1.16.1 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
GHSA-24m8-vm8v-rrfv- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-770, CWE-776
- Updated
- 2026-11-02
OSV
7.5
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
CVE-2021-28302- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2021-28302
7.5
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
DEBIAN-CVE-2021-28302- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-28302
7.5
A stack overflow in pupnp before version 1.14.5 can cause the denial of service through the Parser_parseDocument() function. ixmlNode_free() will release a child node recursively, which will consume stack space and lead to a crash.
- Record
UBUNTU-CVE-2021-28302- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11006-1 No score
libixml11-1.14.10-1.2 on GA media
These are all security issues fixed in the libixml11-1.14.10-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11006-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pupnp-1.8Debian:12 |
All versions, plus listed versions 1:1.8.4-2 |
None known |
libupnpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:1.6.19+git20141001-11:1.6.19+git20141001-1ubuntu11:1.6.19+git20160116-11:1.6.19+git20160116-1ubuntu0.1~esm1 |
None known |
mediatombUbuntu:16.04:LTS |
All versions, plus listed versions 0.12.1-47-g7ab7616-1ubuntu10.12.1-47-g7ab7616-1ubuntu2 |
None known |
libupnpUbuntu:18.04:LTS |
All versions, plus listed versions 1:1.6.22-11:1.6.24-11:1.6.24-21:1.6.24-31:1.6.24-4 |
None known |
pupnp-1.8Ubuntu:18.04:LTS |
All versions, plus listed versions 1:1.8.2-21:1.8.2-3 |
None known |
pupnp-1.8Ubuntu:20.04:LTS |
All versions, plus listed versions 1:1.8.4-2ubuntu2 |
None known |
pupnp-1.8Ubuntu:22.04:LTS |
All versions, plus listed versions 1:1.8.4-2ubuntu2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-28302 is a high vulnerability (CVSS 7.5) in Pupnp Project Pupnp, published March 12, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.15%, the 67th percentile. No source names a fixed version.