CVE-2021-28549
Adobe Photoshop parsing JS buffer overflow vulnerability could lead to arbitrary code execution
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.8
Adobe Photoshop parsing JS buffer overflow vulnerability could lead to arbitrary code execution
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
CVE-2021-28549- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2021-15225
7.8
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
EUVD-2021-15225- CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-282h-pgm7-6q2g No score
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer...
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
GHSA-282h-pgm7-6q2g- Weakness
- CWE-120
- Updated
- 2026-11-02
NVD
7.8
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
CVE-2021-28549- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 7.8 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVALPINE-CVE-2021-28549
7.8
Adobe Photoshop versions 21.2.6 (and earlier) and 22.3 (and earlier) are affected by a Buffer Overflow vulnerability when parsing a specially crafted JSX file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
ALPINE-CVE-2021-28549- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
torAlpine:v3.13 |
before 0.4.4.9-r0 | 0.4.4.9-r0 |
torAlpine:v3.14 |
before 0.4.5.9-r0 | 0.4.5.9-r0 |
torAlpine:v3.15 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.16 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.17 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.18 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.19 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.20 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.21 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.22 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.23 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.24 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-28549 is a high vulnerability (CVSS 7.8) in Adobe Photoshop, published April 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.51%, the 93rd percentile. Fixed in tor 0.4.4.9-r0.