CVE-2021-28550
Adobe Acrobat Reader use after free vulnerability could lead to arbitrary code execution
CVE-2021-28550 is a critical vulnerability (CVSS 9.6) in Adobe Acrobat, published September 2, 2021. CISA lists it as known to be exploited, since November 3, 2021. EUVD reports exploitation since November 3, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 52.1%, the 98th percentile. Fixed in tor 0.4.4.9-r0.
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier) and 2017.011.30194 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.6
Adobe Acrobat Reader use after free vulnerability could lead to arbitrary code execution
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier) and 2017.011.30194 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
CVE-2021-28550- CVSS 3.0
- 9.6 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
EUVDEUVD-2021-15226
9.6
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier) and 2017.011.30194 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
EUVD-2021-15226- CVSS 3.0
- 9.6 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-865h-4rjv-52pg
8.8
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier)...
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier) and 2017.011.30194 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
GHSA-865h-4rjv-52pg- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
CISA KEV No score
Adobe Acrobat and Reader Use-After-Free Vulnerability
Adobe Acrobat and Reader contains a use-after-free vulnerability that could allow an unauthenticated attacker to achieve code execution in the context of the current user.
- Record
CVE-2021-28550- Weakness
- CWE-416
- Updated
- 2026-11-02
NVD
8.8
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier) and 2017.011.30194 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
CVE-2021-28550- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 9.6 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
OSVALPINE-CVE-2021-28550
8.8
Acrobat Reader DC versions versions 2021.001.20150 (and earlier), 2020.001.30020 (and earlier) and 2017.011.30194 (and earlier) are affected by a Use After Free vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
- Record
ALPINE-CVE-2021-28550- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
torAlpine:v3.13 |
before 0.4.4.9-r0 | 0.4.4.9-r0 |
torAlpine:v3.14 |
before 0.4.5.9-r0 | 0.4.5.9-r0 |
torAlpine:v3.15 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.16 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.17 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.18 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.19 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.20 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.21 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.22 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.23 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
torAlpine:v3.24 |
before 0.4.6.5-r0 | 0.4.6.5-r0 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | exploitation | |
| 2026-11-03 | affected, aliases, facts, references | OSV |
| 2026-11-02 | created | CVE List, EUVD, GitHub Advisories, CISA KEV, NVD |