CVE-2021-29417
gitjacker arbitrary code execution
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
- Record
CVE-2021-29417- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
- Record
CVE-2021-29417- Updated
- 2026-11-02
EUVDEUVD-2022-2393 No score
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
- Record
EUVD-2022-2393- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4j5x-f394-xx79
9.8
gitjacker arbitrary code execution
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
- Record
GHSA-4j5x-f394-xx79- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
9.8
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
- Record
CVE-2021-29417- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-4j5x-f394-xx79
9.8
gitjacker arbitrary code execution
gitjacker before 0.1.0 allows remote attackers to execute arbitrary code via a crafted .git directory because of directory traversal.
- Record
GHSA-4j5x-f394-xx79- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGO-2023-1911 No score
gitjacker arbitrary code execution in github.com/liamg/gitjacker
gitjacker arbitrary code execution in github.com/liamg/gitjacker
- Record
GO-2023-1911- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/liamg/gitjackerGo |
before 0.1.0 | 0.1.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-29417 is a critical vulnerability (CVSS 9.8) in Gitjacker Project Gitjacker, published March 29, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.77%, the 89th percentile. Fixed in github.com/liamg/gitjacker 0.1.0.