Every CVE Search/ Get API key

CVE-2021-29450

WordPress Authenticated disclosure of password-protected posts and pages

6.5 MediumFix available

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

2.09%Up 1.5 points since Apr 16, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.5

WordPress Authenticated disclosure of password-protected posts and pages

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
CVE-2021-29450
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
EUVDEUVD-2021-16067 6.5

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
EUVD-2021-16067
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-03
NVD 6.5

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
CVE-2021-29450
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 4.3

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
CVE-2021-29450
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-29450 4.3

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
DEBIAN-CVE-2021-29450
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2021-29450 6.5

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
UBUNTU-CVE-2021-29450
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVBIT-wordpress-2021-29450 No score

WordPress Authenticated disclosure of password-protected posts and pages

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
BIT-wordpress-2021-29450
Updated
2026-11-02
OSVBIT-wordpress-multisite-2021-29450 No score

WordPress Authenticated disclosure of password-protected posts and pages

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Record
BIT-wordpress-multisite-2021-29450
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wordpress
Bitnami
4.7.0 up to 5.7.1
5.7.1
wordpress-multisite
Bitnami
4.7.0 up to 5.7.1
5.7.1
wordpress
Debian:12
before 5.7.1+dfsg1-1
5.7.1+dfsg1-1
wordpress
Debian:13
before 5.7.1+dfsg1-1
5.7.1+dfsg1-1
wordpress
Debian:14
before 5.7.1+dfsg1-1
5.7.1+dfsg1-1
wordpress
Debian:9
From an advisory covering 2 CVEs
before 4.7.20+dfsg-1+deb9u1, plus listed versions
4.7.18+dfsg-1+deb9u14.7.19+dfsg-1+deb9u14.7.5+dfsg-24.7.5+dfsg-2+deb9u14.7.5+dfsg-2+deb9u1~bpo8+1
Show 6 moreShow less
4.7.5+dfsg-2+deb9u24.7.5+dfsg-2+deb9u2~bpo8+14.7.5+dfsg-2+deb9u34.7.5+dfsg-2+deb9u44.7.5+dfsg-2+deb9u54.7.5+dfsg-2+deb9u6
4.7.20+dfsg-1+deb9u1
wordpress
Debian:10
From an advisory covering 2 CVEs
before 5.0.12+dfsg1-0+deb10u1, plus listed versions
5.0.10+dfsg1-0+deb10u15.0.11+dfsg1-0+deb10u15.0.4+dfsg1-15.0.4+dfsg1-1+deb10u15.0.4+dfsg1-1+deb10u2
5.0.12+dfsg1-0+deb10u1
wordpress
Ubuntu:16.04:LTS
All versions, plus listed versions
4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1
None known
wordpress
Ubuntu:18.04:LTS
All versions, plus listed versions
4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1
None known
wordpress
Ubuntu:20.04:LTS
All versions, plus listed versions
5.2.2+dfsg1-15.2.4+dfsg1-15.3.2+dfsg1-15.3.2+dfsg1-1ubuntu1
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
wordpress
Ubuntu:22.04:LTS
All versions, plus listed versions
5.7.1+dfsg1-2ubuntu15.8.1+dfsg1-2ubuntu15.8.2+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu15.8.3+dfsg1-1ubuntu1.1
None known
wordpress
Ubuntu:24.04:LTS
All versions, plus listed versions
6.2+dfsg1-1ubuntu16.4.3+dfsg1-1ubuntu1
None known
wordpress
Ubuntu:25.10
All versions, plus listed versions
6.7.2+dfsg1-1.1ubuntu1
None known
wordpress
Ubuntu:26.10
All versions, plus listed versions
6.7.2+dfsg1-1.1ubuntu2
None known
wordpress
Ubuntu:26.04:LTS
All versions, plus listed versions
6.7.2+dfsg1-1.1ubuntu16.7.2+dfsg1-1.1ubuntu2
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-29450 is a medium vulnerability (CVSS 6.5) in Wordpress, published April 15, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.09%, the 81st percentile. Fixed in wordpress 5.7.1.

References

MoveEnter Open