CVE-2021-29459
XSS Cross Site Scripting
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
9.6
XSS Cross Site Scripting
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
- Record
CVE-2021-29459- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2021-0765
9.6
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
- Record
EUVD-2021-0765- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5c66-v29h-xjh8
9.6
XSS Cross Site Scripting
Impact
It is possible to persistently inject scripts in XWiki.
For unregistred users:
- By filling simple text fields
For registered users:
- By filling their personal information
- (if they have edit rights) By filling the values of static lists using App Within Minutes
That can lead to user's session hijacking, and if used in conjunction with a social engineering attack it can also lead to disclosure of sensitive data, CSRF attacks and other security vulnerabilities. That can also lead to the attacker taking over an account. If the victim has administrative rights it might even lead to code execution on the server, depending on the application and the privileges of the account.
Patches
It has been patched on XWiki 12.8 and 12.6.3.
Workarounds
There is no easy workaround except upgrading XWiki.
References
https://jira.xwiki.org/browse/XWIKI-17374
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki
- Email us at our security mailing list
- Record
GHSA-5c66-v29h-xjh8- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
9.6
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
- Record
CVE-2021-29459- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible to persistently inject scripts in XWiki versions prior to 12.6.3 and 12.8. Unregistred users can fill simple text fields. Registered users can fill in their personal information and (if they have edit rights) fill the values of static lists using App Within Minutes. There is no easy workaround except upgrading XWiki. The vulnerability has been patched on XWiki 12.8 and 12.6.3.
- Record
CVE-2021-29459- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-5c66-v29h-xjh8
9.6
XSS Cross Site Scripting
Impact
It is possible to persistently inject scripts in XWiki.
For unregistred users:
- By filling simple text fields
For registered users:
- By filling their personal information
- (if they have edit rights) By filling the values of static lists using App Within Minutes
That can lead to user's session hijacking, and if used in conjunction with a social engineering attack it can also lead to disclosure of sensitive data, CSRF attacks and other security vulnerabilities. That can also lead to the attacker taking over an account. If the victim has administrative rights it might even lead to code execution on the server, depending on the application and the privileges of the account.
Patches
It has been patched on XWiki 12.8 and 12.6.3.
Workarounds
There is no easy workaround except upgrading XWiki.
References
https://jira.xwiki.org/browse/XWIKI-17374
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki
- Email us at our security mailing list
- Record
GHSA-5c66-v29h-xjh8- CVSS 3.1
- 9.6 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcoreMaven |
before 12.6.3 | 12.6.3 |
org.xwiki.platform:xwiki-platform-oldcoreMaven |
12.6.4 up to 12.8 | 12.8 |
org.xwiki.platform:xwiki-platform-webMaven |
before 12.6.3 | 12.6.3 |
org.xwiki.platform:xwiki-platform-webMaven |
12.6.4 up to 12.8 | 12.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-29459 is a critical vulnerability (CVSS 9.6) in Xwiki, published April 20, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in org.xwiki.platform:xwiki-platform-oldcore 12.6.3.