Every CVE Search/ Get API key

CVE-2021-29943

Apache Solr Unprivileged users may be able to perform unauthorized read/write to collections

9.1 CriticalFix available

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

4.67%Up 4.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.1

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
CVE-2021-29943
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:P/I:P/A:N
Weakness
CWE-863
Updated
2026-11-02
CVE List No score

Apache Solr Unprivileged users may be able to perform unauthorized read/write to collections

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
CVE-2021-29943
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2021-1201 No score

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
EUVD-2021-1201
Updated
2026-11-03
GitHub AdvisoriesGHSA-vf7p-j8x6-xvwp 9.1

Incorrect Authorization in Apache Solr

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
GHSA-vf7p-j8x6-xvwp
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 9.1

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
CVE-2021-29943
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-vf7p-j8x6-xvwp 9.1

Incorrect Authorization in Apache Solr

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
GHSA-vf7p-j8x6-xvwp
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVUBUNTU-CVE-2021-29943 9.1

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
UBUNTU-CVE-2021-29943
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVBIT-solr-2021-29943 No score

Apache Solr Unprivileged users may be able to perform unauthorized read/write to collections

When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.

Record
BIT-solr-2021-29943
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.solr:solr-parent
Maven
before 8.8.2
8.8.2
solr
Bitnami
before 8.8.2
8.8.2
org.apache.solr:solr-parent
Maven
before 8.8.2, plus listed versions
1.3.01.4.01.4.13.1.03.2.0
Show 45 moreShow less
3.3.03.4.03.5.03.6.03.6.13.6.24.0.04.0.0-ALPHA4.0.0-BETA4.1.04.10.04.10.14.10.24.10.34.10.44.2.04.2.14.3.04.3.14.4.04.5.04.5.14.6.04.6.14.7.04.7.14.7.24.8.04.8.14.9.04.9.15.0.05.1.05.2.05.2.15.3.05.3.15.3.25.4.05.4.15.5.05.5.15.5.25.5.35.5.4
8.8.2
lucene-solr
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
3.6.2+dfsg-13.6.2+dfsg-23.6.2+dfsg-2ubuntu0.1~esm13.6.2+dfsg-2ubuntu0.1~esm23.6.2+dfsg-2ubuntu0.1~esm4
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-29943 is a critical vulnerability (CVSS 9.1) in Apache Solr, published April 13, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.67%, the 91st percentile. Fixed in org.apache.solr:solr-parent 8.8.2.

References

This page doesn't list everything

Left out here: 51 versions. The JSON record has them.

MoveEnter Open