Every CVE Search/ Get API key

CVE-2021-30123

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that...

8.8 HighFix available

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.43%Up 1.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
CVE-2021-30123
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
CVE-2021-30123
Updated
2026-11-02
EUVDEUVD-2021-17063 No score

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
EUVD-2021-17063
Updated
2026-11-03
GitHub AdvisoriesGHSA-gx3h-4rx7-q328 No score

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that...

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
GHSA-gx3h-4rx7-q328
Weakness
CWE-120
Updated
2026-11-02
OSVALPINE-CVE-2021-30123 8.8

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
ALPINE-CVE-2021-30123
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
CVE-2021-30123
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-07
OSVJLSEC-2025-112 8.8

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may...

FFmpeg <=4.3 contains a buffer overflow vulnerability in libavcodec through a crafted file that may lead to remote code execution.

Record
JLSEC-2025-112
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.14
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.15
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.16
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.17
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.18
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.19
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.20
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.21
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.22
before 4.4-r0
4.4-r0
ffmpeg
Alpine:v3.23
before 4.4-r0
4.4-r0
Show 9 moreShow less
Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.24
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.16
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.17
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.18
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.19
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.20
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.21
before 4.4-r0
4.4-r0
ffmpeg4
Alpine:v3.22
before 4.4-r0
4.4-r0
FFMPEG_jll
Julia
4.4.0+0 up to 4.4.2+0
4.4.2+0

History

History
RecordedChangedSources
factsOSV
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-30123 is a high vulnerability (CVSS 8.8) in Ffmpeg, published April 7, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.43%, the 89th percentile. Fixed in ffmpeg 4.4-r0.

References

MoveEnter Open