Every CVE Search/ Get API key

CVE-2021-30130

Improper Certificate Validation in phpseclib

7.5 HighFix available

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.05%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
CVE-2021-30130
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-347
Updated
2026-11-02
CVE List No score

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
CVE-2021-30130
Updated
2026-11-02
EUVDEUVD-2021-0879 No score

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
EUVD-2021-0879
Updated
2026-11-03
GitHub AdvisoriesGHSA-vf4w-fg7r-5v94 7.5

Improper Certificate Validation in phpseclib

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
GHSA-vf4w-fg7r-5v94
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-295, CWE-347
Updated
2026-11-02
OSV 7.5

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
CVE-2021-30130
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2021-30130 7.5

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
DEBIAN-CVE-2021-30130
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVGHSA-vf4w-fg7r-5v94 7.5

Improper Certificate Validation in phpseclib

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
GHSA-vf4w-fg7r-5v94
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-295, CWE-347
Updated
2026-11-02
OSVUBUNTU-CVE-2021-30130 7.5

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Record
UBUNTU-CVE-2021-30130
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVCLSA-2026-1779065206 No score

TuxCare security update for phpseclib/phpseclib (4 CVEs)

TuxCare rebuilt phpseclib/phpseclib to address 4 CVEs. Fixed in 0.3.10-p1+tuxcare.

Record
CLSA-2026-1779065206
Updated
2026-11-02
OSVUSN-7404-1 No score

phpseclib vulnerabilities

It was discovered that phpseclib did not correctly handle RSA PKCS#1 v1.5 signature verification. An attacker could possibly use this issue to bypass authentication. This issue only affected Ubuntu 20.04 LTS. (CVE-2021-30130)

It was discovered that phpseclib did not correctly handle certain characters in certain TLS fields, which could lead to name confusion. An attacker could possibly use this issue to bypass authentication. (CVE-2023-52892)

It was discovered that phpseclib incorrectly limited the size of prime numbers generated by isPrime. An attacker could possibly use this issue to cause a denial of service. (CVE-2024-27354)

It was discovered that phpseclib did not correctly handle processing the ASN.1 object identifier of a certificate. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. (CVE-2024-27355)

Record
USN-7404-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpseclib/phpseclib
Packagist
3.0.0 up to 3.0.7
3.0.7
phpseclib/phpseclib
Packagist
before 2.0.31
2.0.31
phpseclib/phpseclib
TuxCare:Packagist
From an advisory covering 4 CVEs
0.3.10 up to 0.3.10-p1+tuxcare
0.3.10-p1+tuxcare
php-phpseclib
Debian:12
before 2.0.30-2
2.0.30-2
php-phpseclib
Debian:13
before 2.0.30-2
2.0.30-2
php-phpseclib
Debian:14
before 2.0.30-2
2.0.30-2
php-phpseclib3
Debian:12
before 3.0.7-1
3.0.7-1
php-phpseclib3
Debian:13
before 3.0.7-1
3.0.7-1
php-phpseclib3
Debian:14
before 3.0.7-1
3.0.7-1
phpseclib
Debian:12
before 1.0.19-3
1.0.19-3
Show 16 moreShow less
Affected packages
PackageAffectedFixed
phpseclib
Debian:13
before 1.0.19-3
1.0.19-3
phpseclib
Debian:10
before 1.0.19-3~deb10u1, plus listed versions
1.0.14-11.0.15-11.0.16-11.0.16-21.0.17-1
Show 4 moreShow less
1.0.18-11.0.18-21.0.19-11.0.19-2
1.0.19-3~deb10u1
php-phpseclib
Debian:10
before 2.0.30-2~deb10u1, plus listed versions
2.0.14-12.0.15-12.0.17-12.0.18-12.0.19-1
Show 14 moreShow less
2.0.20-12.0.21-12.0.21-22.0.21-32.0.22-12.0.23-12.0.23-22.0.25-12.0.26-12.0.27-12.0.28-12.0.29-12.0.29-22.0.30-1
2.0.30-2~deb10u1
phpseclib/phpseclib
Packagist
3.0.0 up to 3.0.7, plus listed versions
3.0.13.0.23.0.33.0.43.0.53.0.6
3.0.7
phpseclib/phpseclib
Packagist
before 2.0.31, plus listed versions
0.3.00.3.10.3.100.3.50.3.6
Show 45 moreShow less
0.3.70.3.80.3.91.0.01.0.11.0.101.0.111.0.121.0.131.0.141.0.151.0.161.0.171.0.181.0.191.0.21.0.201.0.211.0.221.0.231.0.241.0.251.0.261.0.271.0.281.0.291.0.31.0.301.0.41.0.51.0.61.0.71.0.81.0.92.0.02.0.12.0.102.0.112.0.122.0.132.0.142.0.152.0.162.0.172.0.18
2.0.31
php-phpseclib
Ubuntu:Pro:20.04:LTS
before 2.0.23-2ubuntu0.1~esm2, plus listed versions
2.0.21-22.0.23-2
2.0.23-2ubuntu0.1~esm2
phpseclib
Ubuntu:Pro:20.04:LTS
before 1.0.18-2ubuntu0.1~esm1, plus listed versions
1.0.16-21.0.18-2
1.0.18-2ubuntu0.1~esm1
php-phpseclib
Ubuntu:Pro:16.04:LTS
From an advisory covering 4 CVEs
before 2.0.1-1ubuntu0.1~esm2, plus listed versions
2.0.1-12.0.1-1build1
2.0.1-1ubuntu0.1~esm2
phpseclib
Ubuntu:Pro:16.04:LTS
From an advisory covering 4 CVEs
before 1.0.1-3ubuntu0.1+esm1, plus listed versions
0.3.10-31.0.0-21.0.0-31.0.1-11.0.1-31.0.1-3ubuntu0.1
1.0.1-3ubuntu0.1+esm1
php-phpseclib
Ubuntu:Pro:18.04:LTS
From an advisory covering 4 CVEs
before 2.0.9-1ubuntu0.1~esm2, plus listed versions
2.0.6-12.0.7-12.0.9-1
2.0.9-1ubuntu0.1~esm2
phpseclib
Ubuntu:Pro:18.04:LTS
From an advisory covering 4 CVEs
before 1.0.9-1ubuntu0.1~esm1, plus listed versions
1.0.7-11.0.8-11.0.9-1
1.0.9-1ubuntu0.1~esm1
php-phpseclib
Ubuntu:Pro:20.04:LTS
From an advisory covering 4 CVEs
before 2.0.23-2ubuntu0.1~esm2, plus listed versions
2.0.21-22.0.23-2
2.0.23-2ubuntu0.1~esm2
phpseclib
Ubuntu:Pro:20.04:LTS
From an advisory covering 4 CVEs
before 1.0.18-2ubuntu0.1~esm1, plus listed versions
1.0.16-21.0.18-2
1.0.18-2ubuntu0.1~esm1
php-phpseclib
Ubuntu:Pro:22.04:LTS
From an advisory covering 4 CVEs
before 2.0.36-1ubuntu0.1~esm2, plus listed versions
2.0.30-2ubuntu12.0.34-12.0.35-12.0.36-1
2.0.36-1ubuntu0.1~esm2
php-phpseclib3
Ubuntu:Pro:22.04:LTS
From an advisory covering 4 CVEs
before 3.0.13-1ubuntu0.1~esm1, plus listed versions
3.0.9-13.0.10-13.0.12-23.0.13-1
3.0.13-1ubuntu0.1~esm1
phpseclib
Ubuntu:Pro:22.04:LTS
From an advisory covering 4 CVEs
before 1.0.20-1ubuntu0.1~esm1, plus listed versions
1.0.19-3ubuntu21.0.19-3ubuntu31.0.20-1
1.0.20-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-30130 is a high vulnerability (CVSS 7.5) in Phpseclib, published April 6, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.05%, the 64th percentile. Fixed in phpseclib/phpseclib 3.0.7.

References

Show 9 moreShow less
This page doesn't list everything

Left out here: 20 versions. The JSON record has them.

MoveEnter Open